Foros del Web » Programando para Internet » PHP »

problema con rewrite de htaccess

Estas en el tema de problema con rewrite de htaccess en el foro de PHP en Foros del Web. Hola! Estoy usando htaccess por primera vez y hay algo que definitivamente estoy haciendo mal. Tengo un sitio que por ahora es http://localhost/replication Lo que ...
  #1 (permalink)  
Antiguo 07/04/2012, 19:25
 
Fecha de Ingreso: junio-2007
Mensajes: 46
Antigüedad: 12 años, 8 meses
Puntos: 0
problema con rewrite de htaccess

Hola!

Estoy usando htaccess por primera vez y hay algo que definitivamente estoy haciendo mal.

Tengo un sitio que por ahora es http://localhost/replication
Lo que necesito es pasar dos variables usando urls amigables, ejemplo http://localhost/replication/usuario/pagina (ambos son opcionales)

Lei un poco sobre htaccess y logre hacerlo, el problema es que despues de cargar la pagina, se agregan unos caracteres en la barra de direccion, dando como resultado http://localhost/replication/mruser#.T4DWZtXF08w

Aparentemente no afecta el funcionamiento, pero no es muy agradable a la vista asi que si alguien sabe como solucionarlo estaria muy agradecido

Este es el codigo de mi htaccess actualmente:

Options +FollowSymlinks
RewriteEngine on

RewriteRule ^([a-z0-9_-]+)/([a-z0-9_-]+)(/)?$ index.php?username=$1&page=$2 [L]
RewriteRule ^([a-z0-9_-]+)(/)?$ index.php?username=$1



Muchas gracias!

P.D: Ya lo probe en dos sitios online y pasa lo mismo, asi que no creo que sea problema de configuracion del host
  #2 (permalink)  
Antiguo 08/04/2012, 17:49
 
Fecha de Ingreso: junio-2007
Mensajes: 46
Antigüedad: 12 años, 8 meses
Puntos: 0
Respuesta: problema con rewrite de htaccess

bump

sigo sin poder resolverlo, cualquier ayuda es bienvenida

Etiquetas: htaccess, rewrite, variables, usuarios
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 03:20.