Foros del Web » Programando para Internet » PHP »

Problema con select y base de datos

Estas en el tema de Problema con select y base de datos en el foro de PHP en Foros del Web. Hola amigos del Foro: Estoy armando un sitio para un cliente y me he encontrado con el siguiente problema: cuando intento rellenar un <select> con ...
  #1 (permalink)  
Antiguo 29/08/2006, 06:45
 
Fecha de Ingreso: marzo-2003
Ubicación: Chivilcoy
Mensajes: 138
Antigüedad: 14 años, 8 meses
Puntos: 0
Problema con select y base de datos

Hola amigos del Foro:

Estoy armando un sitio para un cliente y me he encontrado con el siguiente problema: cuando intento rellenar un <select> con los registro de una tabla en MySQL, me agrega los <options> a partir del segundo registro, es decir el primer registro de la base no lo muestra.
He usado el mismo código en otros sitios que ya he terminado y nunca tuve problemas. Qué estoy haciendo mal?
Aquí dejo el código que estoy usando para ver si se dan cuenta del error:
Código:
	$rs=mysql_query("Select * from Paises Order by pai_nombre", $conexion);
	$Datos= mysql_fetch_array ($rs);
	while($Datos=mysql_fetch_array($rs))
	{
	<option value="<? echo $Datos["pai_id"] ?>"><? echo $Datos["pai_nombre"] ?></option>
}
Desde ya muchas gracias por su ayuda.
Saludos
__________________
Leandro Mandarano
Cyper Developments
http://www.cyper.com.ar
  #2 (permalink)  
Antiguo 29/08/2006, 06:52
Avatar de Azrael666  
Fecha de Ingreso: noviembre-2004
Mensajes: 652
Antigüedad: 13 años, 1 mes
Puntos: 1
que codigo mas raro.. pa que vuelves a poner <? si ya estas con codigo php? ademas, hazlo asi por lo pronto:

Código PHP:
$rs=mysql_query("Select * from Paises Order by pai_nombre"$conexion);
//$Datos= mysql_fetch_array ($rs); //esto lo quitas que por esto te pilla a partir del 2º
while($Datos=mysql_fetch_array($rs))
{
  echo 
"<option value='".$Datos['pai_id']."'>".$Datos['pai_nombre']."</option>";

por lo demas yo no veo nada.. prueba eso que te puse a ver..
__________________
ALOZORRO v5.0 (ahora en .es)
  #3 (permalink)  
Antiguo 29/08/2006, 13:36
 
Fecha de Ingreso: marzo-2003
Ubicación: Chivilcoy
Mensajes: 138
Antigüedad: 14 años, 8 meses
Puntos: 0
Gracias Azrael666. El problema estaba en esa línea que decis. La saqué y anduvo todo barbaro.
Saludos y gracias
__________________
Leandro Mandarano
Cyper Developments
http://www.cyper.com.ar
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 14:50.