Foros del Web » Programando para Internet » PHP »

Problema con sessions

Estas en el tema de Problema con sessions en el foro de PHP en Foros del Web. Hola colegas, me encunetro en un dilema mayusculo :o Tengo un proyecto en el cual estoy trabajando, el cual trabaja son sessiones, de la manera ...
  #1 (permalink)  
Antiguo 21/04/2006, 19:51
 
Fecha de Ingreso: febrero-2003
Ubicación: Santiago
Mensajes: 220
Antigüedad: 14 años, 10 meses
Puntos: 4
Problema con sessions

Hola colegas, me encunetro en un dilema mayusculo :o

Tengo un proyecto en el cual estoy trabajando, el cual trabaja son sessiones, de la manera tipica

session_start();
$_SESSION[variable] = valor;

mi problema es el siguiente:

Al momento de cargar la pagina web, tengo un IF, que valida si existe
$_SESSION[border], este session se define bien (por lo que estuve verificando) pero resulta que en ALGUNOS equipos pareciera que no lo validara, onda que la pagina no corriera, la url es:

www.colegioalcazar.cl/backup/4ebrio_2006

Estoy desarrollandola, cuando la trate de correr en otro equipo se me queda haciendo un loop, al archivo set_yalgo.php?valor=0 o 1, ojo, que los codigos estan bien, ya que la pagina si me funciona en otros ekipos, pero tambien en artos no....

no hallo que hacer, alguien se el ocurre algo?
Ojo: si estoy dando el session_start(); en el otro archivo, donde se modifica $_SESSION[border], pero esto ya me pillo, alguien? gracias.
__________________
Roberto Osses Elgueta
Senior Web Developer
  #2 (permalink)  
Antiguo 21/04/2006, 20:01
Avatar de jpogsistem  
Fecha de Ingreso: diciembre-2001
Mensajes: 2.405
Antigüedad: 16 años
Puntos: 4
Que tal,

Ese error de cabeceras que saca el link se produce cuando envías algo al navegador como html ó espacios en blanco antes del script que tiene esas cabeceras, que ha de ir de primero para que funcionen bien.

Más que verificar en una u otra másquina, debes probar la compatibilidad con navegadores, o buscar una característica de esas másquinas que afecte la ejecución de tus variables de sesión.

Saludos.
__________________
EL LIMITE ES EL UNIVERSO
  #3 (permalink)  
Antiguo 21/04/2006, 20:08
 
Fecha de Ingreso: febrero-2003
Ubicación: Santiago
Mensajes: 220
Antigüedad: 14 años, 10 meses
Puntos: 4
okale viejo agradesco tu respuesta, veremos que puedo hacer..

Agradeceria si alguien sabe como "compatibilizar este problema"

Resumiendo: "El problema es que en algunos equipos me toma las sessiones creadas, y en otros no " saludos y gracias.
__________________
Roberto Osses Elgueta
Senior Web Developer
  #4 (permalink)  
Antiguo 21/04/2006, 20:13
 
Fecha de Ingreso: junio-2002
Mensajes: 751
Antigüedad: 15 años, 6 meses
Puntos: 22
Utilizas comillas en las variables de session?

$_SESSION['variable'] = valor;
  #5 (permalink)  
Antiguo 21/04/2006, 21:09
 
Fecha de Ingreso: febrero-2003
Ubicación: Santiago
Mensajes: 220
Antigüedad: 14 años, 10 meses
Puntos: 4
uhm

en realidad no, puede ser eso? lo probare, desde ya gracias,
------


no era :(, no se les ocurre nada mas?
__________________
Roberto Osses Elgueta
Senior Web Developer

Última edición por RoKo; 21/04/2006 a las 21:14
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 22:47.