Foros del Web » Programando para Internet » PHP »

Problema con uploads

Estas en el tema de Problema con uploads en el foro de PHP en Foros del Web. Hola como estan todos, espero que bien, bueno al grano; tengo un problema con unos archivos, no los puedo subir por que el tamaño de ...
  #1 (permalink)  
Antiguo 16/03/2006, 17:15
 
Fecha de Ingreso: mayo-2004
Mensajes: 74
Antigüedad: 13 años, 6 meses
Puntos: 0
Problema con uploads

Hola como estan todos, espero que bien, bueno al grano;
tengo un problema con unos archivos, no los puedo subir por que el tamaño de ellos es muy grande (8 a 10MB), ya le cambie el tamaño en el php.ini a 10MB pero no me funciona; con archivos de 1 o 2MB si funciona mi codigo, pero de tamaños mayores, no; que se puede hacer para subir mis demas archivos o no se puede de tan grande tamaño, ma falta cambiar algo???
De antemano muchas gracias y ojala alguien me pueda orientar
__________________
Por muy fuerte que sea la tormenta, al final siempre sale el sol
  #2 (permalink)  
Antiguo 16/03/2006, 22:18
 
Fecha de Ingreso: marzo-2006
Mensajes: 5
Antigüedad: 11 años, 8 meses
Puntos: 0
Mira yo hice algo de esto primero intente haciendolo asi
<?
$destino = 'direccion de donde lo quieres' ;
move_uploaded_file($_FILES['file']['tmp_name'], $destino.'/'. $_FILES['file']['name']);
?>

pero me dio unos bateos y luego lo que hice fue esto:
//esto es cogiendolo de un formulario donde le doy la opcion al usuario de buscar lo que quiere
//archivo es el nombre del input tipo file
//en el copy le pasa $archivo,y el otro parametro es la ruta donde lo quieres y ya


if ($archivo != "none" && $archivo_size != 0)
{ $archivo_name=$Nick.$archivo_name ;
if (! copy ($archivo, "../avatares_usuarios/".$archivo_name))
{
$texto=".No se ha podido copiar el archivo.";
header("Location: ../paginas/redire_time.php.?mensaje=$texto&&url=$dire");
exit;
}
}
else
if ($archivo!="none" && $archivo_size == 0 && $archivo_name!="")
{
$texto=".Tamaño de archivo superado.";
header("Location: ../paginas/redire_time.php.?mensaje=$texto&&url=$dire");
exit;
}
else
{
$textow="Sin avatar";
}

//espero que te sirva de algo escribeme si tienes alguna duda
  #3 (permalink)  
Antiguo 17/03/2006, 07:21
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Revisa esta FAQ:

http://www.forosdelweb.com/showpost....&postcount=146

No sé que configuración concreta modificastes o como quedó toda (y tampoco sabemos si reiniciastes tu servidor para que los cambios queden afectados o bien lo comprobastes en última instancia via: phpinfo() ..)

Un saludo,
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:32.