Foros del Web » Programando para Internet » PHP »

[SOLUCIONADO] Problema con el uso de Echo

Estas en el tema de Problema con el uso de Echo en el foro de PHP en Foros del Web. Hola Expertos de Php. mi pregunta es la siguiente como puedo usar de otra forma lo siguiente. echo ' onclick="window.open(this.href,'emailWindow','widt h=400,height=450,location=no,menubar=no,resizable= no,scrollbars=no'); return false;" '; ...
  #1 (permalink)  
Antiguo 25/09/2015, 11:30
Avatar de webelgrillo  
Fecha de Ingreso: marzo-2008
Mensajes: 142
Antigüedad: 10 años, 6 meses
Puntos: 0
Sonrisa Problema con el uso de Echo

Hola Expertos de Php.

mi pregunta es la siguiente como puedo usar de otra forma lo siguiente.

echo '
onclick="window.open(this.href,'emailWindow','widt h=400,height=450,location=no,menubar=no,resizable= no,scrollbars=no'); return false;"
';

si lo pongo de esta forma manda error!!!

en algún código alguna vez vi que ponen algo para que se ejecute lo que esta dentro de la comilla y respete su contenido.

Por favor ayudenme quiero saber como se podría hacer para que se ejecute con normalidad lo que esta dentro de las comillas del echo.

gracias.
  #2 (permalink)  
Antiguo 25/09/2015, 13:58
Colaborador
 
Fecha de Ingreso: mayo-2008
Ubicación: $MX['VZ']['Xalapa']
Mensajes: 3.005
Antigüedad: 10 años, 5 meses
Puntos: 528
Respuesta: Problema con el uso de Echo

Debes aprender a utilizar los caracteres de escape, en este foro hay un post que te enseña a usarlos.

De pronto, para tu ejemplo si empiezas el echo con apóstrofes, debes escapar los apóstrofes interiores:

Código PHP:
Ver original
  1. echo '
  2. onclick="window.open(this.href,\'emailWindow\',.........';
  #3 (permalink)  
Antiguo 25/09/2015, 13:59
Avatar de Triby
Mod on free time
 
Fecha de Ingreso: agosto-2008
Ubicación: $MX->Gto['León'];
Mensajes: 9.874
Antigüedad: 10 años, 2 meses
Puntos: 2152
Respuesta: Problema con el uso de Echo

Lee esto: http://www.forosdelweb.com/f18/como-...s-bien-588701/
__________________
- León, Guanajuato
- GV-Foto
  #4 (permalink)  
Antiguo 26/09/2015, 08:18
Avatar de webelgrillo  
Fecha de Ingreso: marzo-2008
Mensajes: 142
Antigüedad: 10 años, 6 meses
Puntos: 0
Respuesta: Problema con el uso de Echo

gracias por la ayuda aprendi mucho

Etiquetas: echo
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 18:09.