Foros del Web » Programando para Internet » PHP »

Problema con variables de sistema y otras.

Estas en el tema de Problema con variables de sistema y otras. en el foro de PHP en Foros del Web. Hola, ke tal todos? no se si tiene ke ver con la versión de php ke usa mi servidor o ke pero el caso es ...
  #1 (permalink)  
Antiguo 08/07/2004, 03:20
 
Fecha de Ingreso: mayo-2004
Mensajes: 89
Antigüedad: 13 años, 7 meses
Puntos: 0
Problema con variables de sistema y otras.

Hola, ke tal todos? no se si tiene ke ver con la versión de php ke usa mi servidor o ke pero el caso es ke tengo problemas con las varibales de sistema y otras, por ejemplo:

$HTTP_REFERER no me devuelve ningún valor, o $REMOTE_ADDR tampoco, nunca, y por ejemplo $HTTP_POST_VARS si me devuelve correctamente los valores mediante $HTTP_POST_VARS["variable"] en fin que no se ke pasa, alguien puede iluminarme?

Gracias un saludo (por cierto es urgente).
  #2 (permalink)  
Antiguo 08/07/2004, 03:37
Avatar de Tximis  
Fecha de Ingreso: junio-2004
Ubicación: Bilbao
Mensajes: 328
Antigüedad: 13 años, 6 meses
Puntos: 2
Prueba con:

Código:
$_SERVER['HTTP_REFERER']
$_SERVER['REMOTE_ADDR ']
La variable HTTP_REFERER almacena la última página visitada antes de entrar a la nuestra, puede no exitir o puede ser omitida, algunos navegadores lo hacen.

Un saludo.
  #3 (permalink)  
Antiguo 08/07/2004, 05:13
 
Fecha de Ingreso: mayo-2004
Mensajes: 89
Antigüedad: 13 años, 7 meses
Puntos: 0
Ei pues así sí, qué versión es esa? por qué con la otra no?
uff ke lio.. (soy nueva en esto, se nota? xD)
He detectado ke la version de php ke usa mi servidor es 4.3.6 ... es normal ke no me salga como antes? eske busco manuales y manuales y cada uno me dice que haga las cosas de una manera distinta.. ke rollo :/

Un saludo
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:28.