Foros del Web » Programando para Internet » PHP »

Problema con variables variables

Estas en el tema de Problema con variables variables en el foro de PHP en Foros del Web. Hola estoy utilizando variables variables en un script pero al parecerno me lo reconoce. El codigo donde falla es el siguiente: Código PHP:   while( ...
  #1 (permalink)  
Antiguo 26/04/2004, 02:03
 
Fecha de Ingreso: marzo-2002
Ubicación: Guadalajara, Jalisco.
Mensajes: 213
Antigüedad: 15 años, 9 meses
Puntos: 0
Problema con variables variables

Hola estoy utilizando variables variables en un script pero al parecerno me lo reconoce.

El codigo donde falla es el siguiente:
Código PHP:
 while($resultado mysql_fetch_array($nombre))
  {
   
$id_producto $resultado['id_producto'];
   
$descrip_prod $resultado['descrip_prod'];
   echo
"<option value=${'clave' . $id_producto . 'mat' . $iCont}>$descrip_prod</option>";
             } 
Al momento de ver el codgo fuente aparece <option value=>(valor de $descrip_prod)</option>.

alguien sabe porque no se muestra mi variable variable?

Saludos!
__________________
Edgar Castro
Estudiante de Ingenieria en Sistemas @ ITESO
http://www.iteso.mx
  #2 (permalink)  
Antiguo 26/04/2004, 02:12
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 5 meses
Puntos: 16
Hola,

¿Por que no lo haces en varias lineas? Seria mas claro y mas dificil equivocarse:
Código PHP:
while($resultado mysql_fetch_array($nombre))

  {

   
$id_producto $resultado['id_producto'];

   
$descrip_prod $resultado['descrip_prod'];

  
$temp=${'clave' $id_producto 'mat' $iCont};
   echo
"<option value=\"$temp\">$descrip_prod</option>";

             } 
Tambien deberias mirar si las variables que usas para crear el nombre tienen los valores correctos.

Saludos.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
  #3 (permalink)  
Antiguo 26/04/2004, 14:19
 
Fecha de Ingreso: marzo-2002
Ubicación: Guadalajara, Jalisco.
Mensajes: 213
Antigüedad: 15 años, 9 meses
Puntos: 0
Gracias por tu respuesta pero sigue sin funcionar, también ya revisé que los nombres de las variables estén correctos.

Alguna otra sugerencia?
__________________
Edgar Castro
Estudiante de Ingenieria en Sistemas @ ITESO
http://www.iteso.mx
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 20:55.