Foros del Web » Programando para Internet » PHP »

Problema con Wamp y BBDD

Estas en el tema de Problema con Wamp y BBDD en el foro de PHP en Foros del Web. Tengo instalado Wamp 5, y todo funciona correctamente. Estoy empezando a crear una aplicación, que inserta unos registros en una BBDD mysql, pero no me ...
  #1 (permalink)  
Antiguo 05/12/2005, 08:24
 
Fecha de Ingreso: diciembre-2005
Mensajes: 9
Antigüedad: 12 años
Puntos: 0
Problema con Wamp y BBDD

Tengo instalado Wamp 5, y todo funciona correctamente. Estoy empezando a crear una aplicación, que inserta unos registros en una BBDD mysql, pero no me inserta nada.

En los privilegios de phpmyadmin, tengo puesto el usuario root, con el servidor localhost y con una contraseña, pues bien, cuando utilizo esta aplicación, el código que utilizo es:

<?
$servidor="localhost";
$usuario="root";
$password="micontraseña";
$bd="clientes";
$conexion=mysql_connect($servidor,$usuario,$passwo rd);
mysql_select_db($bd,$conexion);
$insertar = "INSERT into empresas (empresa,sociedad,contacto,cif,telefono,telefono2, fax,direccion,localidad,postal,provincia,email,web ) VALUES ('$empresa','$sociedad','$contacto','$cif','$telef ono','$telefono2','$fax','$direccion','$localidad' ,'$postal','$provincia','$email','$web')";
$hazlo= mysql_query($conexion,$insertar);
?>

Pero no me inserta nada,¿qué está mal? ¿qué puedo hacer?
  #2 (permalink)  
Antiguo 05/12/2005, 08:54
Avatar de Seppo  
Fecha de Ingreso: marzo-2005
Ubicación: Buenos Aires, Argentina
Mensajes: 1.284
Antigüedad: 12 años, 9 meses
Puntos: 17
resource mysql_query ( string query [, resource identificador_de_enlace] )

$hazlo= mysql_query($insertar,$conexion); deberías usar
  #3 (permalink)  
Antiguo 06/12/2005, 01:29
 
Fecha de Ingreso: diciembre-2005
Mensajes: 9
Antigüedad: 12 años
Puntos: 0
Nada de nada, sigue sin funcionar.

Esto me tiene un tanto liado, ya que no se que hacer ya, yo me imagino que puede ser más que problema del código, problema de configuración, pero ya no se que tocar, ya que he modicado los privilegios, poniendo como usuario root, servidor localhost y contraseña, además todo esto también lo he incluido en el fichero config.inc.php, pero nada, sigue igual.

Si por lo menos tuviera algún mensaje de error sabría por donde tirar más o menos, pero de este modo no se que hacer.

Espero vuestra ayuda.
Un saludo.
  #4 (permalink)  
Antiguo 07/12/2005, 03:23
Avatar de jam1138
/** @package Moderador */
 
Fecha de Ingreso: julio-2004
Ubicación: sèveR led onieR lE
Mensajes: 9.368
Antigüedad: 13 años, 4 meses
Puntos: 101
Código PHP:
<?php
$servidor
="localhost";
$usuario="root";
$password="micontraseña";
$bd="clientes";
$conexionmysql_connect($servidor,$usuario,$password) or die(mysql_error());
mysql_select_db($bd,$conexion) or die(mysql_error());
$insertar "INSERT into empresas (empresa,sociedad,contacto,cif,telefono,telefono2, fax,direccion,localidad,postal,provincia,email,web ) VALUES ('$empresa','$sociedad','$contacto','$cif','$telef ono','$telefono2','$fax','$direccion','$localidad' ,'$postal','$provincia','$email','$web')";
$hazlomysql_query($insertar,$conexion) or die(mysql_error());
?>
¿qué pasa?

__________________
٩(͡๏̯͡๏)۶
» Cómo hacer preguntas de manera inteligente «

"100 años después, la revolución no es con armas, es intelectual y digital"
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 18:31.