Foros del Web » Programando para Internet » PHP »

Problema configurando gettext

Estas en el tema de Problema configurando gettext en el foro de PHP en Foros del Web. Hola, tengo una aplicación web a la que quiero introducir internacionlaización. Leí acerca del gettext, siguiendo tutoriales como este . Pero sigo sin obtener las ...
  #1 (permalink)  
Antiguo 11/06/2011, 12:50
 
Fecha de Ingreso: marzo-2010
Mensajes: 73
Antigüedad: 9 años, 4 meses
Puntos: 0
Problema configurando gettext

Hola,
tengo una aplicación web a la que quiero introducir internacionlaización.
Leí acerca del gettext, siguiendo tutoriales como este. Pero sigo sin obtener las traducciones.

He creado un pequeño script en php para poder testear bajo strace, con la misma configuración que tengo en mi aplicación, situándolo en el mismo directorio, como si guera un fichero más de la misma. Lo añado a continuación:

Código PHP:
<?php
// Idioma

$lang 'es_ES.utf8';

 

// Dominio

$text_domain 'blanca';

 

// Dependiendo de tu OS putenv/setlocale configurarán tu idioma.

putenv('LC_ALL='.$lang);

setlocale(LC_ALL$lang);

 

// La ruta a los archivos de traducción

bindtextdomain($text_domain'./gettext/locale' );

 

// El codeset del textdomain

bind_textdomain_codeset($text_domain'UTF-8');

 

// El Textdomain

textdomain($text_domain);


// Print a test message
echo gettext("User");


// Or use the alias _() for gettext()
echo _("User");
?>

Tras la ejecución de este comando:
strace -e trace=file -o test.txt php prog.php

Añado los resultados obtenidos en test.txt, sólo la parte relacionada con la apertura de los ficheros que contienen las traducciones:

Cita:
open("prog.php", O_RDONLY) = 3
getcwd("/opt/lampp/htdocs/blanca", 4096) = 25
lstat("/opt/lampp/htdocs/blanca/prog.php", {st_mode=S_IFREG|0644, st_size=521, ...}) = 0
lstat("/opt/lampp/htdocs/blanca", {st_mode=S_IFDIR|0777, st_size=4096, ...}) = 0
lstat("/opt/lampp/htdocs", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
lstat("/opt/lampp", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
lstat("/opt", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
getcwd("/opt/lampp/htdocs/blanca", 4096) = 25
lstat("/opt/lampp/htdocs/blanca/./locale", 0x7fffb2c1a670) = -1 ENOENT (No such file or directory)
open("/usr/share/locale/locale.alias", O_RDONLY) = 3
open("/usr/share/locale/es_ES.utf8/LC_MESSAGES/blanca/gettext.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/share/locale/es_ES/LC_MESSAGES/blanca/gettext.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/share/locale/es.utf8/LC_MESSAGES/blanca/gettext.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/share/locale/es/LC_MESSAGES/blanca/gettext.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/share/locale-langpack/es_ES.utf8/LC_MESSAGES/blanca/gettext.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/share/locale-langpack/es_ES/LC_MESSAGES/blanca/gettext.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/share/locale-langpack/es.utf8/LC_MESSAGES/blanca/gettext.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/share/locale-langpack/es/LC_MESSAGES/blanca/gettext.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
He jugado con los parámetros, pero sin suerte, si alguien me pudiera ayudar, lo agradecería mucho!!

Añado también las rutas de mi aplicación y de los ficheros de traducciones:
Aplicación: /opt/lampp/htdocs/blanca (en xammp, abriéndola como http://localhost/blanca/)
Traducciones: /opt/lampp/htdocs/blanca/gettext/locale/es_ES/LC_MESSAGES/blanca.mo

/opt/lampp/htdocs/blanca/gettext/locale/es_ES/LC_MESSAGES/blanca.po

Etiquetas: gettext
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 05:49.