Foros del Web » Programando para Internet » PHP »

Problema al enviar mail en html

Estas en el tema de Problema al enviar mail en html en el foro de PHP en Foros del Web. Estimados amigos quería saludarlos por estas fiestas y desearles que el año 2003 sea realmente bueno para todos y se cumplan más cosas que las ...
  #1 (permalink)  
Antiguo 26/12/2002, 13:48
 
Fecha de Ingreso: abril-2002
Ubicación: Argentina
Mensajes: 96
Antigüedad: 15 años, 8 meses
Puntos: 0
Pregunta Problema al enviar mail en html

Estimados amigos quería saludarlos por estas fiestas y desearles que el año 2003 sea realmente bueno para todos y se cumplan más cosas que las espectativas que tengan.

También los molesto por una consulta, tengo hecho un script que lo que haces es procesar un formulario y enviarlo en html, ya que luego la persona que lo recibe con un simple Reply lo contesta en el caso de que sea necesario. Funcionó sin problemas hasta que mudamos el web site de server y ahora los mails llegan en código html así:

Código:
Content-type: text/html; charset=iso-8859-1
From: GUSTAVO ASBORNO <[email protected]>
<html>
<head>
<title>Respuesta de Evaluaci&oacute;n</title>
<meta http-equiv='Content-Type' content='text/html; charset=iso-8859-1'>
</head>
<body bgcolor='#FFF8DC' text='#000000' link='#990000' vlink='#CC0000'
alink='#990000'>
<p align='center'><font face='Times New Roman, Times, serif'
size='4'><b>Observatorio de Salud<br>
<font size='3' color='#990000'>Medicamentos y Sociedad<br>
</font></b></font><font face='Verdana, Arial, Helvetica, sans-serif' size='1'><a href='http://www.observatoriodesalud.org.ar'>http://www.observatoriodesalud.org.ar</a></font></p>
<table width='70%' border='0' cellspacing='1' cellpadding='3' bgcolor='#000000'>
y sigue....

Qué puede haber pasado?
Les agradezco su posible respuesta
Saludos cordiales
Sergio Bosetti
  #2 (permalink)  
Antiguo 26/12/2002, 14:41
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 6 meses
Puntos: 16
Hola,

¿Has pasado de un servidor Windows a un Unix/Linux o viceversa y en el codigo usabas explicitamente el salto de linea especifico del SO ('\n')? Pon el codigo que usas para enviar el mail, sobre todo donde especificas las cabeceras.

Saludos.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 23:54.