Foros del Web » Programando para Internet » PHP »

Problema al enviar mail en PHP

Estas en el tema de Problema al enviar mail en PHP en el foro de PHP en Foros del Web. Buenas! Tengo una página en PHP que he diseñado con Dreamweaver que me manda por mail el resultado de un formulario. La cuestión es que ...
  #1 (permalink)  
Antiguo 17/05/2005, 04:05
 
Fecha de Ingreso: mayo-2005
Mensajes: 5
Antigüedad: 12 años, 7 meses
Puntos: 0
Problema al enviar mail en PHP

Buenas!
Tengo una página en PHP que he diseñado con Dreamweaver que me manda por mail el resultado de un formulario. La cuestión es que me envia bien por mail el html y las variables del formulario, pero además necesito que me envie tambien unas consultas de la base de datos y varios resultados de funciones PHP que he hecho, y eso no consigo que me lo mande. En la misma página me imprimo una copia del formulario y eso si me lo imprime bien, por lo que no es problema de que no lo reciba bien del formulario anterior ni de la base de datos.
Os pongo un poco del código para que veais como lo estoy haciendo, aunque igual el problema es que no lo admite simplemente.


// esto va dentro del cuerpo del mail entre comillas
.........

<table width=\"515\" border=\"1\" align=\"left\" cellpadding=\"0\" cellspacing=\"0\" bordercolor=\"#000000\" id=\"datos\"><div align=\"left\" class=\"Estilo4\">
<tr>
<td>FECHA</td>
<td>echo ".ImprimeFecha($fecha)."</td>
</tr>
<tr>
<td>GESTOR ADMINISTRATIVO </td>
<td>".$row_Usuarios['Nombre']." ".$row_Usuarios['Apellidos']."</td>
</tr>
<tr>
<td>DNI</td>
<td>".$row_Usuarios['DNI']."</td>
</tr>
</div></table>
.......
<tr>
<td><div align=\"center\">1.1</div></td>
<td><div align=\"center\">66.60 &euro;</div></td>
<td><div align=\"center\">".$_POST["c11"]."</div></td>
<td><div align=\"center\">".ImprimirImporte(MultiplicarCant idad("c11",66.6))."</div></td>
</tr>
.......
Lo que va en la variable $_POST si me lo manda, pero lo de $row_Usuarios y lo de las funciones ImprimeFecha e ImprimeImporte no me lo manda, es más, me lo imprime en la página.

A ver si me podeis echar una mano.
Muchas gracias, un saludo.
Sergio
  #2 (permalink)  
Antiguo 17/05/2005, 13:03
 
Fecha de Ingreso: mayo-2005
Mensajes: 5
Antigüedad: 12 años, 7 meses
Puntos: 0
Por favor, ¿alguien me puede ayudar? es que es lo único que me falta para terminar la página y me están apretando para que está lista ya. Os lo agradeceré eternamente.
Un saludo, Sergio
  #3 (permalink)  
Antiguo 17/05/2005, 13:11
Avatar de dwaks  
Fecha de Ingreso: agosto-2002
Ubicación: Panamá
Mensajes: 962
Antigüedad: 15 años, 4 meses
Puntos: 15
Imprime estos valores $row_Usuarios['Nombre'] aparte para ver si tienen valores y comenzar a detectar de donde viene el error.
  #4 (permalink)  
Antiguo 17/05/2005, 16:34
 
Fecha de Ingreso: mayo-2005
Mensajes: 5
Antigüedad: 12 años, 7 meses
Puntos: 0
Muchas gracias por contestar dwaks, probaré a hacer eso, aunque en la misma página uso las mismas consultas de la base de datos dentro de un formulario y las saca por pantalla perfectamente, con lo que, en teoría, debería funcionar ahí también. Ya comentaré estas pruebas a ver que sale.

Un saludo, Sergio
  #5 (permalink)  
Antiguo 18/05/2005, 03:24
 
Fecha de Ingreso: mayo-2005
Mensajes: 5
Antigüedad: 12 años, 7 meses
Puntos: 0
Problema casi resuelto

Ya he resuelto casi todo el problema. La cuestion estaba en que las funciones de imprimir devolvian un echo, y eso no lo tragaba el cuerpo del mail. COn poner un return en esas funciones ya va perfectamente. Para resolver las consultas he hecho una funcion que devuelve la consulta y ya está. Lo unico que sigue sin tragar es una funcion que me suma todas las cantidades que se van multiplicando a traves de una variable global que se va actualizando en la funcion que multiplica. En el formulario si funciona, pero en el cuerpo del mail no lo traga. ¿Sabeis alguna alternativa para usar en vez de la variable global?
Lo que hace la funcion es multiplicar una cantidad fija por un número que se introduce en el formulario en cada casilla. Entonces necesito la suma total de todas las multiplicaciones.

Muchas gracias.
Un saludo, Sergio
  #6 (permalink)  
Antiguo 18/05/2005, 04:08
 
Fecha de Ingreso: mayo-2005
Mensajes: 5
Antigüedad: 12 años, 7 meses
Puntos: 0
De acuerdo Solucionado

Problema finiquitado. Muchas gracias.
Un saludo, Sergio
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:51.