Foros del Web » Programando para Internet » PHP »

Problema de envio de variables

Estas en el tema de Problema de envio de variables en el foro de PHP en Foros del Web. Buenas a todos. Estoy intentando pasar dos variables por URL mediante un hipervinculo. La primera me la envia correctamente, pero la segunda aparentemente no. href="resp.php?texto='.$resultado.'&mensaje='.$men ...
  #1 (permalink)  
Antiguo 02/01/2003, 15:57
 
Fecha de Ingreso: septiembre-2002
Mensajes: 34
Antigüedad: 15 años, 3 meses
Puntos: 0
Problema de envio de variables

Buenas a todos.

Estoy intentando pasar dos variables por URL mediante un hipervinculo.
La primera me la envia correctamente, pero la segunda aparentemente no.

href="resp.php?texto='.$resultado.'&mensaje='.$men saje.' ">

Alguien sabe a q es es debido y tiene alguna solucion possible?


Zanks, Joan.
  #2 (permalink)  
Antiguo 02/01/2003, 16:30
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
El link que muestras está incompleto ..

Debería ser:
Código PHP:
echo "<a href=\"resp.php?texto=$resultado&mensaje=$mensaje\">bla bla</a>"
O tambien:
Código PHP:
echo '<a href="resp.php?texto='.$resultado.'&mensaje='.$mensaje.'">bla bla</a>'
y cuidado si pasas frases (palabras separadas por espacios ..) depende de la configuración de tu PHP .. deberas usar urldecode() y/o stripslashes() donde recojas el valor de las variables implicadas ..

Un saludo,
  #3 (permalink)  
Antiguo 02/01/2003, 16:34
Avatar de chalito  
Fecha de Ingreso: diciembre-2002
Ubicación: Santiago, chile
Mensajes: 221
Antigüedad: 15 años
Puntos: 0
como ya lo aclaro Cluster, estas haciendo mal uso de las comillas, debes fijarte bien como se distribullen o como se concatenan las cadenas

Saludos
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta

SíEste tema le ha gustado a 1 personas




La zona horaria es GMT -6. Ahora son las 16:47.