Foros del Web » Programando para Internet » PHP »

Problema Extraño $PHP_AUTH_USER

Estas en el tema de Problema Extraño $PHP_AUTH_USER en el foro de PHP en Foros del Web. Pues verán tengo el típico ejemplo que esta por ahi, if(!isset($PHP_AUTH_USER)){ codigo para que aparezca el recuadro ese }else{ echo "Hola: ". $PHP_AUTH_USER } Sin ...
  #1 (permalink)  
Antiguo 24/05/2004, 16:09
 
Fecha de Ingreso: junio-2003
Ubicación: Asturias
Mensajes: 2.427
Antigüedad: 14 años, 6 meses
Puntos: 7
Problema Extraño $PHP_AUTH_USER

Pues verán tengo el típico ejemplo que esta por ahi,

if(!isset($PHP_AUTH_USER)){
codigo para que aparezca el recuadro ese
}else{
echo "Hola: ". $PHP_AUTH_USER
}

Sin embargo, el recuadro me aparece, pero cuando meto un usuario y una contraseña, en teoria, deberia de aparecerme ya el mensaje:

Hola UsuarioTal

¿Verdad?

Pues nada, mete un usuario y una contraseña, y me vuelve a salir el recuadro, asi hasta tres veces. Pero, teniendo encuenta el poco código que he puesto, ¿No debería de aparecerme directamente el usuario que yo he metido ya que en TEORIA deberia existir ya la variable $PHP_AUTH_USER?

En fin, espero que puedan echarme una mano, y desde ya, gracias.
__________________
Charlie.
  #2 (permalink)  
Antiguo 25/05/2004, 01:26
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 5 meses
Puntos: 16
Hola,

Tal como lo tienes, necesitas register_globals a ON. Prueba con $_SERVER['PHP_AUTH_USER'].

Mas en http://www.php.net/manual/en/features.http-auth.php

Saludos.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:32.