Foros del Web » Programando para Internet » PHP »

problema al insertar registro con adodb y campo autoincrement

Estas en el tema de problema al insertar registro con adodb y campo autoincrement en el foro de PHP en Foros del Web. Hola a todos, tengo un problema, utilizo la clase adodb y tengo una tabla en mysql con un campo primary key y autoincrementable llamado: id, ...
  #1 (permalink)  
Antiguo 28/08/2006, 22:47
 
Fecha de Ingreso: noviembre-2005
Mensajes: 78
Antigüedad: 12 años, 1 mes
Puntos: 0
problema al insertar registro con adodb y campo autoincrement

Hola a todos,

tengo un problema, utilizo la clase adodb y tengo una tabla en mysql con un campo primary key y autoincrementable llamado: id, como siempre me arrojaba error fui eliminado todos los campos para dar con el error y me quede con solo 2 campos y me sigue saliendo el error, el codigo es el sgte:
Código PHP:
$query "insert into  asistencia (gestion) values ('2006')";
       echo 
"la consulta es: ".$query;
       
$datos $conn1->Execute("$query");   // linea 73 
el error es el sgte:
Código PHP:
consulta esinsert into asistencia (gestionvalues ('2006')
Fatal errorCall to a member function Execute() on a non-object in C:Archivos de programaApache GroupApache2htdocsproyecto_3AsistenciafuncionesDB.php on line 73 
Ya intente poner:
$query = "insert into asistencia (id,gestion) values (NULL,'2006')";
$query = "insert into asistencia (id,gestion) values ('','2006')";

y nada, por lo que me arroja un error fatal no puedo ver el error, pero como hice un echo a la consulta, cuando la copio y la pego al phpmyadmin funciona bien, tal vez alguien me pudiera orientar al respecto sobre como escribir la consulta correctamente y tambien como capturar errores en adodb,

gracias de antemano,

saludos.
  #2 (permalink)  
Antiguo 28/08/2006, 23:14
 
Fecha de Ingreso: junio-2005
Mensajes: 981
Antigüedad: 12 años, 6 meses
Puntos: 2
Nunca utilice adodb, pero el mensaje del error es muy claro, estas llamando a una funcion que no existe. Fijate si la instancia de la classe se instancio bien... tal vez sea que no es $conn1->Execute() sino $conn1->execute(), recuerda que se distingue entre mayusculas y minusculas. No se en que mas te puedo ayudar... pero el error es ese (no existe esa funcion o lo que es igual es que no esta definida).

Saludos.
  #3 (permalink)  
Antiguo 29/08/2006, 09:10
 
Fecha de Ingreso: noviembre-2005
Mensajes: 78
Antigüedad: 12 años, 1 mes
Puntos: 0
Hola DarioDario,

gracias por la respuesta, me sirvio mucho, el error era que al llamar a la clase adodb estaba utilizando include_once solo puse include y funciono,
saludos,
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:05.