Foros del Web » Programando para Internet » PHP »

problema en instalacion de php

Estas en el tema de problema en instalacion de php en el foro de PHP en Foros del Web. soy un principiante en linux, acabo de instalar fedora 2 y trate de instalar apache, mysql y php con la siguiente secuencia que encontre en ...
  #1 (permalink)  
Antiguo 28/06/2004, 04:52
 
Fecha de Ingreso: abril-2004
Ubicación: Valparaiso
Mensajes: 7
Antigüedad: 13 años, 8 meses
Puntos: 0
problema en instalacion de php

soy un principiante en linux, acabo de instalar fedora 2 y trate de instalar apache, mysql y php con la siguiente secuencia que encontre en el sitio de php, obviamente cambiando las versiones:
1. gunzip apache_1.3.14.tar.gz
2. tar xvf apache_1.3.14.tar
3. gunzip php-4.0.3pl1.tar.gz
4. tar xvf php-4.0.3pl1.tar
5. cd apache_1.3.14
6. ./configure --prefix=/usr/local/apache
7. cd ../php-4.0.3pl1
8. ./configure --with-mysql --with-apache=../apache_1.3.14 --enable-track-vars
9. make
10. make install
11. cp libs/libphp4.a ../apache_1.3.14/src/modules/php4/
12. cd ../apache_1.3.14
13. ./configure --activate-module=src/modules/php4/libphp4.a
14. make
15. make install

el asunto es que la carpeta libs esta vacia, y por lo tanto no puedo ejecutar las 11 y 13
alguien me podria decir que hago en este caso?

por si sirve de algo baje los siguientes archivos:
httpd-2.0.49.tar.gz
MySQL-server-4.0.20-0.i386.rpm
php-4.3.7.tar.gz
  #2 (permalink)  
Antiguo 28/06/2004, 07:20
 
Fecha de Ingreso: febrero-2004
Mensajes: 221
Antigüedad: 13 años, 10 meses
Puntos: 0
No es necesario que copies libphp4.a
No hagas el paso 11 y disfruta ;)

Ah y te comento que para hacer --with-mysql vas a necesitar la librería instalada libmysqlclient, o para tu distribución, el paquete MySQL-client-4.0.20-0.i386.rpm
  #3 (permalink)  
Antiguo 28/06/2004, 12:17
 
Fecha de Ingreso: abril-2004
Ubicación: Valparaiso
Mensajes: 7
Antigüedad: 13 años, 8 meses
Puntos: 0
hola, o sea que tampoco es necesario reconfigurar el apache???? (paso 13) o utilizo la misma linea 6 en la 13?
y lo otro
si te entendi bien, tengo que instalar:
MySQL-server-4.0.20-0.i386.rpm y MySQL-client-4.0.20-0.i386.rpm
antes de ejecutar estos pasos?

gracias por tu respuesta
  #4 (permalink)  
Antiguo 28/06/2004, 14:25
 
Fecha de Ingreso: febrero-2004
Mensajes: 221
Antigüedad: 13 años, 10 meses
Puntos: 0
Vos antes que nada instala los dos paquetes de MySQL.
Luego ejecuta los pasos asi
1. gunzip apache_1.3.14.tar.gz
2. tar xvf apache_1.3.14.tar
3. gunzip php-4.0.3pl1.tar.gz
4. tar xvf php-4.0.3pl1.tar
5. cd apache_1.3.14
6. ./configure --prefix=/usr/local/apache
7. cd ../php-4.0.3pl1
8. ./configure --with-mysql --with-apache=../apache_1.3.14 --enable-track-vars
9. make
10. make install
11. cd ../apache_1.3.14
12. ./configure --activate-module=src/modules/php4/libphp4.a
13. make
14. make install

y listo.
  #5 (permalink)  
Antiguo 28/06/2004, 14:37
 
Fecha de Ingreso: abril-2004
Ubicación: Valparaiso
Mensajes: 7
Antigüedad: 13 años, 8 meses
Puntos: 0
en la linea 12 (tuya) me sale el siguiente error:

[[email protected] httpd-2.0.49]# ./configure --activate-module=src/modules/php4/libphp4.a
configure: error: unrecognized option: --activate-module=src/modules/php4/libphp4.a
Try `./configure --help' for more information.

por lo que entiendo esta haciendo referencia al mismo archivo que no estaba
que hago?
  #6 (permalink)  
Antiguo 28/06/2004, 19:11
 
Fecha de Ingreso: febrero-2004
Mensajes: 221
Antigüedad: 13 años, 10 meses
Puntos: 0
Para, vos me estas mintiendo
Tenes el paquete apache_1.3.14.tar.gz y me salis con httpd-2.0.49, que son dos ramas diferentes de apache la 1.x y la 2.x
Hace todo con el paquete apache_1.3.14.tar.gz!
  #7 (permalink)  
Antiguo 28/06/2004, 19:18
 
Fecha de Ingreso: abril-2004
Ubicación: Valparaiso
Mensajes: 7
Antigüedad: 13 años, 8 meses
Puntos: 0
Cita:
Iniciado por AirBorn
soy un principiante en linux, acabo de instalar fedora 2 y trate de instalar apache, mysql y php con la siguiente secuencia que encontre en el sitio de php, "obviamente cambiando las versiones":

por si sirve de algo baje los siguientes archivos:
httpd-2.0.49.tar.gz
MySQL-server-4.0.20-0.i386.rpm
php-4.3.7.tar.gz
eso es lo que baje y trate de instalar, en vez de apache 1.3.14 baje el apache 2, por lo tanto, donde decia "apache_1.3.14" lo cambiaba por "httpd-2.0.49"
yo pense que cambiando las versiones era suficiente.
no es lo mismo?
  #8 (permalink)  
Antiguo 28/06/2004, 19:43
 
Fecha de Ingreso: junio-2004
Mensajes: 97
Antigüedad: 13 años, 5 meses
Puntos: 0
Disculpen si estoy equivocado pero hasta donde yo sabia apache, mysql and php no necesitan ser instalados manualmente porque el setup de fedora lo hace por ti. Yo instale fedora 1 en mi pc y todo esta bien.
__________________
hackerhosting.com
  #9 (permalink)  
Antiguo 29/06/2004, 08:45
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
hackerhosting ..

Bueno .. como para "windows" tienens esos "pre-instaladores" .. la mayoría de distribuciones de linux tienen sus paquetes instaladores como los RPM de Fedora/Red Had o los equivalentes de Debian .. etc.

Ahora .. si quieres hacer las cosas por ti mismo y saber lo que estás instalando ademas de usar las últimas versiones de los mismos (Apache, PHP, Mysql .. etc) con configuración personalizada .. pues tendras que instalarlo manualmente= Compliarlo a mano.

Un saludo,
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 08:33.