Foros del Web » Programando para Internet » PHP »

Problema instalando librería GD

Estas en el tema de Problema instalando librería GD en el foro de PHP en Foros del Web. Hola a [email protected], Tengo un pequeño problema con la "instalación" de la librería GD. Tengo Apache bajo WinXP y php 4.4.1. He estado mirando los ...
  #1 (permalink)  
Antiguo 27/07/2006, 15:33
 
Fecha de Ingreso: marzo-2004
Ubicación: Sureste
Mensajes: 186
Antigüedad: 13 años, 9 meses
Puntos: 0
Problema instalando librería GD

Hola a [email protected],

Tengo un pequeño problema con la "instalación" de la librería GD. Tengo Apache bajo WinXP y php 4.4.1. He estado mirando los mensajes del foro y tengo:

extension_dir="c:/php/ext/"
extension=php_gd2.dll
(quitado el ;)

He verificado que el archivo php_gd2.dll esté en su sitio correcto, lo he vuelto a descargar y lo he copiado encima por si acaso el archivo estaba corrupto.

Después de cada cambio he reiniciado el servidor.

Y al hacer un phpinfo() no aparece nada de librería GD, ni el servidor Apache me da errores ni nada.

No sé qué puede ser. ¿Alguna idea?

Gracias y un saludo.
  #2 (permalink)  
Antiguo 27/07/2006, 15:55
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Cita:
He verificado que el archivo php_gd2.dll esté en su sitio correcto, lo he vuelto a descargar y lo he copiado encima por si acaso el archivo estaba corrupto.
Y de "donde" lo has descargado? .. Las extensiones en windows se pre-compilan para la versión exacta de PHP que uses .. así que no sirve tomar cualquier "php_xxx.dll" que encuentres por ahí .. debe ser exactamente el que venga con la distribución de PHP para windows (el "zip package" las tiene no la versión "windows installer")

También fijate bien que php.ini editastes, el que debes editar es el que te dice en el phpinfo() (en el primer bloque de información donde está y cual es).

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
  #3 (permalink)  
Antiguo 28/07/2006, 02:43
 
Fecha de Ingreso: marzo-2004
Ubicación: Sureste
Mensajes: 186
Antigüedad: 13 años, 9 meses
Puntos: 0
Pues lo descargué de php.net, para la versión 4.4.1 que es la que me da el phpinfo. El php.ini que tengo editado es el que figura en la ruta de los datos que me da el phpinfo.

La cuestión es que no me da ningún tipo de error, ni aparece gd por ningún lado. :?
  #4 (permalink)  
Antiguo 23/08/2006, 11:57
 
Fecha de Ingreso: marzo-2004
Ubicación: Sureste
Mensajes: 186
Antigüedad: 13 años, 9 meses
Puntos: 0
Bueno, al final conseguí que andara la librería GD, pero tuve que formatear el PC. Posiblemente fuera que ya le iba haciendo falta.

Saludos!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 22:37.