Foros del Web » Programando para Internet » PHP »

Problema Link

Estas en el tema de Problema Link en el foro de PHP en Foros del Web. Buenas noches, tengo un problema que no he podido responder y ya me esta sacando de casillas, tengo el siguiente script de PHP : <? ...
  #1 (permalink)  
Antiguo 13/08/2003, 01:31
 
Fecha de Ingreso: marzo-2003
Ubicación: Bogotá
Mensajes: 199
Antigüedad: 14 años, 9 meses
Puntos: 0
Problema Link

Buenas noches, tengo un problema que no he podido responder y ya me esta sacando de casillas, tengo el siguiente script de PHP :

<?

echo("<a href='javascript:newWin1('vermas.php?id=" . $row1["posicion_prin"] . "','','width=630,height=500');' class='vermas'>ver mas</a>");

?>

Este script lo que hace es: tengo una página, en la cual tengo un "ver mas" y cuando doy click se me abre otra página y paso una variable que va cambiando ya que este script lo tengo dentro de un for, pero cuando coloco el cursor del mouse sobre el link este sale incompleo, sale : javascript:newWin1( y nada mas, u cuando doy click me sale un error de Java y no se que sera, porqeu cuando dejo el href fuera del php si funciona, pero no me envia las variables, el código que así es :

<a href="javascript:newWin1('vermas.php?id= <? $row1["posicion_prin"] ?> ','','width=630,height=500');" class="vermas">ver mas</a>

este último código no me saca errores, pero el lick me sale así:
javascript:newWin1('vermas.php?id= ', .....etc)

pero como ven sin el id, no m trae nada el php cuando se que si esta trayendo algo,

Alguien me puede ayudar porfavor, sugerencias o alguna otra forma de hacerlos. ????

Gracias
  #2 (permalink)  
Antiguo 13/08/2003, 01:37
Avatar de lado2mx
Colaborador
 
Fecha de Ingreso: agosto-2001
Ubicación: Veracruz
Mensajes: 3.720
Antigüedad: 16 años, 4 meses
Puntos: 9
Código PHP:
 <a href="javascript:newWin1('vermas.php?id=<? $row1["posicion_prin"]; ?> ','','width=630,height=500');" class="vermas">ver mas</a>
Usa esto, suerte...
  #3 (permalink)  
Antiguo 13/08/2003, 16:44
 
Fecha de Ingreso: marzo-2003
Ubicación: Bogotá
Mensajes: 199
Antigüedad: 14 años, 9 meses
Puntos: 0
No funciona.....

Nada, de nada, no funciona tampoco así, se va a la página nueva, pero no envia los datos, queda así :
id='', ....etc

el id queda vacio, y no se porque, que podra ser???? ayuda por favorrrrrr

Este es el script:
<a href="javascript:newWin1('vermas.php?id=<? $row1["posicion_prin"]; ?> ','','width=630,height=500');" class="vermas">ver mas</a>
  #4 (permalink)  
Antiguo 13/08/2003, 17:03
Avatar de Manoloweb  
Fecha de Ingreso: enero-2002
Ubicación: Monterrey
Mensajes: 2.454
Antigüedad: 15 años, 10 meses
Puntos: 5
Código PHP:
<a href="javascript:newWin1('vermas.php?id=<?= $row1["posicion_prin"]; ?> ','','width=630,height=500');" class="vermas">ver mas</a>
__________________
Manoloweb
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 12:42.