Foros del Web » Programando para Internet » PHP »

Problema al mandar mails

Estas en el tema de Problema al mandar mails en el foro de PHP en Foros del Web. Hola, estoy haciendo en mi web lo típico de "manda esto a un amigo". Bien simplemente usar la función mail(...). El caso es que lo ...
  #1 (permalink)  
Antiguo 11/10/2004, 06:09
Avatar de caerolus  
Fecha de Ingreso: agosto-2004
Ubicación: Madrid, España
Mensajes: 280
Antigüedad: 13 años, 3 meses
Puntos: 1
Problema al mandar mails

Hola, estoy haciendo en mi web lo típico de "manda esto a un amigo".
Bien simplemente usar la función mail(...). El caso es que lo q quiero mandar realmente es una página html que redireccione a la página que se quiere mandar al amiguete.
Pues bien, si no me equivoco, hay q hacer esto no? Lo he sacado un poco de la web oficial de php.
Código PHP:
mail("[email protected]",
    
"subject",
    
"<html><head><META HTTP-EQUIV=\"Refresh\" CONTENT=\"0; url=www.caerolus.com/musica/comentarios/ver.php?id=002\"></head></html>",
    
"From: [url]www.caerolus.com[/url] <[email protected]>\r\n"
    
."MIME-Version: 1.0\r\n"
    
."Content-type: text/html; charset=iso-8859-1"); 
Pues bien, si mando eso no sale nada en el mensaje, está totalmente en blanco.
Sin embargo, si pongo algo simple como esto:
Código PHP:
mail("[email protected]",
    
"subject",
    
"<html><head></head><body>hola</body>",
    
"From: [url]www.caerolus.com[/url] <[email protected]>\r\n"
    
."MIME-Version: 1.0\r\n"
    
."Content-type: text/html; charset=iso-8859-1"); 
pues se muestra el mensaje correctamente (un simple "hola").
Hago algo mal? o esque no puedo hacerlo redireccionando?
Gracias
  #2 (permalink)  
Antiguo 12/10/2004, 07:30
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
En tu primer ejemplo .. el HTML que haces extrictamente no es correcto .. deberías usar las etiquetas <body> </body> aunque dentro no hagas nada .. Por lo demás .. si ese redireccionamiento que haces en la cabecera HTTP no se ejecuta .. es normal que veas una página en blanco por qué en el "body" no muestras nada.

El hecho de que tu cliente de correo (ya sea este tipo "web mail" o "software" tipo Outlook, The Bat! .. o similares) ejecute esa "cabecera" es cosa particular de la configuración de ese cliente de correo. Hay mucho cliente de correo que no permite "linkeos" externos (Hotmail, Outlook bajo Windows XP con Service Pack 2 tiene un bloque para todo eso que debes "permitir" si lo deseas ...). En otros casos se "confunde" tu <head> </head> (el de tu e-mail que generas y envias) con el própio <head> </head> de un webmail común donde se "incrustra" tu HTML bajo el <body> </body> de la página en sí (se solventa si ese webmail puede trabajar bajo frame/imframe para mostrar el mensaje u otras técnicas).

En esa "página" en blanco que ves .. edita el código fuente y observa que código ves .. SI ves tu código (+otro tal vez dependiendo del cliente de correo que uses) .. y no se ejecuta .. no le heches la culpa a PHP y como generas el e-mail sino a la configuración/tipo de cliente de correo que usas para ver ese e-mail.

Lo más sano es que envies un link hacia tu página y listo .. así no tendrás problemas con clientes de correo que no permitan o hagan ese tipo de redireccionamientos.

Un saludo,
  #3 (permalink)  
Antiguo 30/10/2004, 03:19
 
Fecha de Ingreso: octubre-2004
Ubicación: Ixtapa-Zihuatanejo Gro,Mex
Mensajes: 1
Antigüedad: 13 años, 1 mes
Puntos: 0
Pregunta

Hola amigos help me.. Bueno quiero mandar un mail con un fondo personalizado(alguna imagen en partic.)
He utilizado Outlook Ex. pero me he dado cuenta que llegan SIN fondo He intentado pegar el codigo html en el cuerpo del mail(en este caso es hotmail)con sus archivos adjuntos, pero al enviarlo solo llega las etiketas HTML jeje.. No entiendooo

Help me, que estoy haciendo mal o de plano no se puede?.
si saben.. envienme
[email protected]
  #4 (permalink)  
Antiguo 31/10/2004, 11:07
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
peman .. la filosofìa de los foros en general es que se trate el tema por aquì .. de todas formas tu e-mail ahí queda por si alguien te quiere contactar.

Para concretar tu pregunta .. deberías indicar primeramente si realmente estás usando PHP para generar ese e-mail (parece que NO) ..Si es así .. usa el foro de "Ayuda general" (para que te orienten o manden a otro foro ..) pero no uses el de "PHP"!!!.

Un saludo,
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 07:40.