Foros del Web » Programando para Internet » PHP »

Problema al mostrar datos de una consulta

Estas en el tema de Problema al mostrar datos de una consulta en el foro de PHP en Foros del Web. Buenas de nuevo ^^ Vereis estoy intentando sacar informacion de mi base de datos y mostrarlo en una pequeña tabla, organizada. Aparte de que no ...
  #1 (permalink)  
Antiguo 01/08/2006, 19:54
Avatar de Epifanio999  
Fecha de Ingreso: abril-2006
Ubicación: Frente mi pantalla
Mensajes: 32
Antigüedad: 11 años, 7 meses
Puntos: 0
Problema al mostrar datos de una consulta

Buenas de nuevo ^^

Vereis estoy intentando sacar informacion de mi base de datos y mostrarlo en una pequeña tabla, organizada.

Aparte de que no lo consigo, este tema si me podeis ayudar con alguna web donde venga bien explicado o alguna ayuda sera muy bien recibida :)

Os pongo el codigo para sacar la info de la base de datos...

<a href="prueba.php?accion=mostrar">Mostrar</a>
<?php
/*Posts*/

if ($accion=="mostrar");
{

/*REALIZA LA CONEXION Y SACA LOS DATOS*/
$db = mysql_pconnect("localhost","*****", "*****r");
mysql_select_db("*****",$db);
$sql = "SELECT (nombreserie, tiposerie, informacion, nombregrupo, webgrupo) datosseries";

/*SACA EL NUMERO DE FILAS*/
$num_results = $result->numRows();


/*MUESTRA LOS DATOS CON TODAS LAS FILAS*/
for ($i=0; $i <$num_results; $i++)
{
$row = $result->fetchRow(DB_FETCHMODE_ASSOC);
echo "<p><strong>'.($i+1).'.NOMBRE DE LA SERIE: ";
echo htmlspecialchars (stripslashes($row['nombreserie']));
echo "</strong><br />TIPO DE SERIE: ";
echo stripslashes($row['tiposerie']);
echo "</strong><br />INFORMACION: ";
echo stripslashes($row['informacion']);
echo "</strong><br />NOMBRE DEL GRUPO QUE TRADUCE: ";
echo stripslashes($row['nombregrupo']);
echo "</strong><br />WEB DEL GRUPO QUE TRADUCE: ";
echo stripslashes($row['webgrupo']);
echo "</p>";
}
}
?>

La idea es que cuando pulse mostrar aparezcan los datos, pero sin embargo no muestra nada, y no me carga entera la web, ya que tiene mas cosas por que este texto esta en la parte de contenido, el resto funciona bien. Pero aun asi sigue sin ir cambiandolo de varias maneras...

Gracias por adelantado
  #2 (permalink)  
Antiguo 02/08/2006, 02:24
Avatar de ProgramadorMax  
Fecha de Ingreso: diciembre-2003
Ubicación: Ciudad de Mexico.
Mensajes: 47
Antigüedad: 14 años
Puntos: 0
Podrias colocar el codigo de tus funciones y clases constructoras, para poder ver cual es el problema en mas detalle y no solo en la parte que nos muestras.

Saludos
__________________
Tonto es aquel que tiene el conocimiento y no sabe como usarlo...
Solo destripando creo mostruos de soluciones.
  #3 (permalink)  
Antiguo 02/08/2006, 03:47
Avatar de djreficul  
Fecha de Ingreso: julio-2006
Ubicación: Cork
Mensajes: 672
Antigüedad: 11 años, 5 meses
Puntos: 0
En la parte que nos muestras... donde realizas la query? Veo q generas la sentencia pero no que la ejecutes.

Saludos.
__________________
La muerte es un camino que todos debemos recorrer...
  #4 (permalink)  
Antiguo 02/08/2006, 03:59
Avatar de Azrael666  
Fecha de Ingreso: noviembre-2004
Mensajes: 652
Antigüedad: 13 años, 1 mes
Puntos: 1
te dejo un codigo que uso yo para mostrar los datos de una tabla de la base de datos..

Código PHP:
$link[email protected]mysql_connect($server,$usuario,$pass)or die (exit(mysql_error()));
  
mysql_select_db($base);


  
$sql="select *  from tabla where loquesea ";
  
$resultado=mysql_query($sql)or die ("ERROR obteniendo respuestas de la base de datos, ".mysql_error());
$contenido="<html>
<head>
<title>titulo</title>
<meta http-equiv='Content-Type' content='text/html; charset=iso-8859-1'>
</head>
<body><center>"
;

    
$contenido.="<table width='70%' border='1' cellspacing='0' cellpadding='0'>
  <tr>
    <td width='29%'><b>columna1</b></td>
    <td width='71%'><b>columna2</b></td>
  </tr>
"
;
 while(
$registro mysql_fetch_row($resultado))
      
$contenido.="<tr>
    <td width='30%'>"
.$registro[2]."</td>
    <td width='70%'>"
.$registro[0]."</td>
  </tr>"
;
$contenido.="</table></center></body>
</html>"
;


print 
$contenido

joer.. fui a tomar un cafe y se me olvido darle a enviar jajaja. fijo que ya hay mas mensajes.. pero en fin... lo subo..
__________________
ALOZORRO v5.0 (ahora en .es)
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 11:39.