Foros del Web » Programando para Internet » PHP »

Problema!! el mysql_connect no me hace nada :(

Estas en el tema de Problema!! el mysql_connect no me hace nada :( en el foro de PHP en Foros del Web. Hola! Pues soy bastante nueva por estos temas y necesitaba conectarme a una base de datos de MySQL a través de PHP. Para ello realizo ...
  #1 (permalink)  
Antiguo 08/02/2009, 14:26
 
Fecha de Ingreso: febrero-2009
Mensajes: 47
Antigüedad: 10 años, 10 meses
Puntos: 0
Problema!! el mysql_connect no me hace nada :(

Hola!

Pues soy bastante nueva por estos temas y necesitaba conectarme a una base de datos de MySQL a través de PHP. Para ello realizo lo siguiente:

<?php
echo "Antes de entrar...\n";

$link = mysql_connect("localhost", "root", "contraseña");
if (!$link) {
die(mysql_error());
}
echo "Despues de entrar\n";
?>

Pues reluslta que ni me suelta errores ni me escribe el echo que hay después... he probado en poner constantes de texto dentro del die pero tampoco me las escribe... si no hay error pero no sigue no sé que pasa.

El Apache PHP y MySQL los instalé apartir del paquete XAMPP, y el MYSQL sé que me funciona porque lo puedo administrar por MYSQL administrator sin problema, y me he conectado exteriormente para importar una hoja de Excel, así que también he podido conectarme con un programa que he encontrado.

¿A alguién se le ocurre algo??

Muchas gracias :D
  #2 (permalink)  
Antiguo 08/02/2009, 15:19
Avatar de Genetix  
Fecha de Ingreso: febrero-2002
Ubicación: Lima - Perú
Mensajes: 1.600
Antigüedad: 17 años, 10 meses
Puntos: 45
Respuesta: Problema!! el mysql_connect no me hace nada :(

Hola
Prueba conectarte desde la consola de comandos si se conecta sin problemas es un problema de configuración de PHP

Saludos!
__________________
"El conocimiento nos hace responsables."
twitter: @benjamingb
blog personal: http://codigolinea.com
ZF Manual en español http://manual.zfdes.com
  #3 (permalink)  
Antiguo 08/02/2009, 16:42
okram
Invitado
 
Mensajes: n/a
Puntos:
Respuesta: Problema!! el mysql_connect no me hace nada :(

Es un error de programación que nada tiene que ver con MySQL

Función de la sección de Base de Datos


Vé el código fuente HTML generado por ese script. Si ves el código PHP, entonces tu servidor no está interpretando el código PHP.

  #4 (permalink)  
Antiguo 08/02/2009, 23:47
 
Fecha de Ingreso: febrero-2009
Mensajes: 47
Antigüedad: 10 años, 10 meses
Puntos: 0
Respuesta: Problema!! el mysql_connect no me hace nada :(

Hola! muchas gracias por vuestras respuestas, ya lo he solucionado
Comento por si le sirve a alguien en un futuro:

Yo instalé el XAMPP, pero hacía mucho tiempo había instalado ya PHP, asi que el archivo php.ini que me estaba cogiendo no era el que yo había editado para descomentar los .dll que perimten el acceso a MySQL. Con esto:
<?php
phpinfo();
?>

Vi que php.ini me estaba cogiendo y efectivamente no estaba bien configurado, por eso no me entraba a la base de datos :D... sólo me costó una 6 o 7 horas

Muchas gracias por las aportaciones :D

Última edición por mmjj; 08/02/2009 a las 23:56
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 07:37.