Foros del Web » Programando para Internet » PHP »

Problema "peculiar" con sessiones

Estas en el tema de Problema "peculiar" con sessiones en el foro de PHP en Foros del Web. Que tal? En una página donde se logean los usuauros uso variables de session $_SESSION["usuauro"], pero pasa algo bien curioso (por lo menos para mí). ...
  #1 (permalink)  
Antiguo 26/10/2005, 11:38
 
Fecha de Ingreso: octubre-2005
Mensajes: 9
Antigüedad: 12 años, 1 mes
Puntos: 0
Exclamación Problema "peculiar" con sessiones

Que tal?

En una página donde se logean los usuauros uso variables de session $_SESSION["usuauro"], pero pasa algo bien curioso (por lo menos para mí). Cuando pongo la ruta con la dirección IP del servidor si si me respeta las sesiones pero cuando uso el nombre del servidor no!. Me explico.

http://123.007.666.1/sitioweb/ -> SI me funcionan las sessiones

http://server_fulano/sitioweb/ -> No me funcionan las sessiones

¿Alguien sabe a que se debe?, ¿tendrá solución?

Por todo gracias totales...
  #2 (permalink)  
Antiguo 26/10/2005, 11:58
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Como propagas el SID en tu sistema (sesiones) .. .lo haces por cookies o por el URL? ..

Podría ser que tengas problemas con las cookies que generase PHP para propagar el SID .. en ese caso, revisa tu navegador que tipo de cookies está aceptado.

Un saludo,
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:02.