Foros del Web » Programando para Internet » PHP »

Problema de PHP con apache

Estas en el tema de Problema de PHP con apache en el foro de PHP en Foros del Web. Hola tengo instalado el servidor apache 2.0.47 y cuando le doy start me sale un cartel que dice: Unknown():Unable to load dynamic library c:/php/extensions/php_ifx.dll - ...
  #1 (permalink)  
Antiguo 27/10/2003, 23:20
 
Fecha de Ingreso: febrero-2003
Mensajes: 4
Antigüedad: 14 años, 9 meses
Puntos: 0
Problema de PHP con apache

Hola tengo instalado el servidor apache 2.0.47 y cuando le doy start me sale un cartel que dice:
Unknown():Unable to load dynamic library c:/php/extensions/php_ifx.dll - No se puede hallar uno de los archivos de la biblioteca necesarios para ejecutar esta aplicacion.
Y el mismo mensaje para php_imap.dll, php_mcrypt.dll, php_oci8.dll, php_oracle.dll y php_sybase_ct.dll
Pero esos archivos estan en la carpeta de php.
No se si tenga que ver pero todabia no instale MySql.
Y otra aclaracion es que segui las instrucciones del tutorial para instalar apache, phpmyadmin, php, mysql de Negrete.
Saludos.
  #2 (permalink)  
Antiguo 27/10/2003, 23:50
 
Fecha de Ingreso: agosto-2002
Ubicación: Colón - Entre Rios - Argentina
Mensajes: 647
Antigüedad: 15 años, 3 meses
Puntos: 8
Prueba copiar las .dll que estan en la carpeta dlls (del directorio php) a alguna carpeta que este dentro del path del sistema. Como por ej. c:\windows\system

Saludos!
  #3 (permalink)  
Antiguo 28/10/2003, 08:27
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
No todas las extensiones funcionan por si solas habilitando las:

extension=php_xxxx.dll

de tu PHP.ini. Muchas requieren de librerias extra que no vienen con el .zip de PHP. Cada una de esas librerias extra las indica el manual de PHP en su apartado correspondiente al tema de las funciones que uses.

Por ejemplo:
php_mcrypt.dll

requiere de más librerias adicionales o de una versión "empaquetada" de esas librerias. En las FAQ's de este foro dejé una al respecto.

Un saludo,


Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
  #4 (permalink)  
Antiguo 28/10/2003, 08:36
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 5 meses
Puntos: 16
Hola,

Si vas a la pagina del manual donde tienes una descripcion de la extension, siempre te dice que tienes que tener instalado para que funcione esa extension. Por ejemplo en www.php.net/oci8 te dice que tienes que tener instaladas las librerias del cliente de Oracle.

Saludos.

PD: Solo te queda uno, Cluster.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:15.