Foros del Web » Programando para Internet » PHP »

problema registro usuarios

Estas en el tema de problema registro usuarios en el foro de PHP en Foros del Web. hola tengo una web con registro de usuarios, desde que me e cambiado la conecxion de internet y tengo router cuando algien se registra le ...
  #1 (permalink)  
Antiguo 18/04/2005, 09:04
 
Fecha de Ingreso: junio-2004
Mensajes: 65
Antigüedad: 13 años, 5 meses
Puntos: 0
problema registro usuarios

hola tengo una web con registro de usuarios, desde que me e cambiado la conecxion de internet y tengo router cuando algien se registra le sale este mensage : Warning: session_start(): Cannot send session cookie - headers already sent by (output started at c:\appserv\www\registrar.php:109) in c:\appserv\www\config.php on line 12

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at c:\appserv\www\registrar.php:109) in c:\appserv\www\config.php on line 12

el registro se realiza pero no se por que sale eso.
  #2 (permalink)  
Antiguo 18/04/2005, 09:20
 
Fecha de Ingreso: julio-2003
Ubicación: Colombia
Mensajes: 591
Antigüedad: 14 años, 4 meses
Puntos: 7
En tu codigo lo primero que debes hacer es iniciar la sesion (o no iniciarla), en vez de cualquier salto de linea o codigo HTML, o salida (echo) de PHP...

Chaop!
  #3 (permalink)  
Antiguo 18/04/2005, 09:21
 
Fecha de Ingreso: diciembre-2002
Mensajes: 341
Antigüedad: 15 años
Puntos: 0
Lo que pasa es que estas tratando de enviar una (o dos) cabecerá HTTP en la linea 12 de config.php y las cabeceras HTTP se deben enviar antes que el propio cuerpo o texto de la página.

Pero tu archivo registrar.php imprime algo antes de enviar estas cabeceras, entonces cuando config.php intenta enviar las cabeceras no puede, porque registrar.php ya ha mostrado algo.

Por lo tanto, comprueba la linea 109 de registrar.php. Tal vez haya un error, o simplemente imprimes algo o si es la última linea del archivo posiblemente este imprimiendo espacio en blanco.

Un saludo
__________________
guebs - alojamiento web y dominios
www.guebs.com
blog.guebs.com
  #4 (permalink)  
Antiguo 18/04/2005, 11:15
 
Fecha de Ingreso: junio-2004
Mensajes: 65
Antigüedad: 13 años, 5 meses
Puntos: 0
gracias por responder, el problema era que no se por que abia quitado la conec a la base de datos al principio del codigo de la pagina
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 10:33.