Foros del Web » Programando para Internet » PHP »

Problema al subir imagenes

Estas en el tema de Problema al subir imagenes en el foro de PHP en Foros del Web. Hola que tal, tengo un script que sube imagenes a un directorio de mi web, el problema está en que las imagenes se suben sin ...
  #1 (permalink)  
Antiguo 04/07/2005, 01:09
 
Fecha de Ingreso: marzo-2002
Ubicación: Guadalajara, Jalisco.
Mensajes: 213
Antigüedad: 15 años, 9 meses
Puntos: 0
Problema al subir imagenes

Hola que tal, tengo un script que sube imagenes a un directorio de mi web, el problema está en que las imagenes se suben sin permismo de lectura, por lo que tengo que cambiar manualmente el permiso para leerlas y evitar que me aparezca un error 403 al accesar a la url de la imagen.

¿Existes alguna manera de darle propiedades de lectura directamente al subirla?

El código lo saque de un mensaje de estos foros hace unos meses:
Código:
$ruta='/www/f/fsmexcom/htdocs/img/temp/'; 
 $archivo=$ruta.$_FILES['userfile']['name'];
 $nombre_foto=$_FILES['userfile']['name'];
 if (is_uploaded_file($_FILES['userfile']['tmp_name'])) 
  { 
   move_uploaded_file($_FILES['userfile']['tmp_name'],$archivo); 
  }
 else
  { 
   echo "Possible file upload attack. Filename: " . $_FILES['userfile']['name']; 
  }
Espero que me puedan ayudar.

Saludos desde México
__________________
Edgar Castro
Estudiante de Ingenieria en Sistemas @ ITESO
http://www.iteso.mx
  #2 (permalink)  
Antiguo 04/07/2005, 10:35
Avatar de PabloP  
Fecha de Ingreso: marzo-2005
Mensajes: 83
Antigüedad: 12 años, 8 meses
Puntos: 0
Lo que tienes que hacer es cambiar los permisos del archio despues de subirlo

$ruta='/www/f/fsmexcom/htdocs/img/temp/';
$archivo=$ruta.$_FILES['userfile']['name'];
$nombre_foto=$_FILES['userfile']['name'];
if (is_uploaded_file($_FILES['userfile']['tmp_name']))
{
move_uploaded_file($_FILES['userfile']['tmp_name'],$archivo);
chmod ('ruta del archivo/'.$archivo, 0777); //agrega esto.
}
else
{
echo "Possible file upload attack. Filename: " . $_FILES['userfile']['name'];
}
  #3 (permalink)  
Antiguo 04/07/2005, 11:32
 
Fecha de Ingreso: marzo-2002
Ubicación: Guadalajara, Jalisco.
Mensajes: 213
Antigüedad: 15 años, 9 meses
Puntos: 0
Muchisimas gracias PabloP, funciona a la perfección.

Saludos!
__________________
Edgar Castro
Estudiante de Ingenieria en Sistemas @ ITESO
http://www.iteso.mx
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:02.