Foros del Web » Programando para Internet » PHP »

Problema de tildes con botón "me gusta" facebook

Estas en el tema de Problema de tildes con botón "me gusta" facebook en el foro de PHP en Foros del Web. Hola! Tengo una pagina php donde he incorporado el botón "me gusta" de facebook. Todo perfecto, cada "entrada" tiene el botón de me gusta que ...
  #1 (permalink)  
Antiguo 02/01/2011, 09:19
 
Fecha de Ingreso: junio-2006
Ubicación: España
Mensajes: 122
Antigüedad: 13 años, 6 meses
Puntos: 2
Problema de tildes con botón "me gusta" facebook

Hola! Tengo una pagina php donde he incorporado el botón "me gusta" de facebook.

Todo perfecto, cada "entrada" tiene el botón de me gusta que sale de la forma

a x persona le gusta "el tema" a mipagina.com

el problema viene cuando una de las entradas tiene una tilde, que entonces cuando sale el mensaje ese en facebook salen simbolos extaños en vez de la tilde.

en su dia ya tube que tocar el charset para que me mostrara bien las tildes en mi pagina web. uso:

Código HTML:
Ver original
  1. <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="ES" lang="ES">
  2. <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />
  3. <meta name="title" content="<?php echo $title; ?>" />
  4. <meta name="description" content="<?php echo $title; ?>" />

he probado en poner utf8_decode en las meta etiquetas "title" y "description" y nada.

alguna idea?

gracias
  #2 (permalink)  
Antiguo 02/01/2011, 12:17
Avatar de pateketrueke
Modernizr
 
Fecha de Ingreso: abril-2008
Ubicación: Mexihco-Tenochtitlan
Mensajes: 26.399
Antigüedad: 11 años, 8 meses
Puntos: 2534
Respuesta: Problema de tildes con botón "me gusta" facebook

y se te ocurrió, tal ves, cambiar el charset a UTF-8?
__________________
Y U NO RTFM? щ(ºдºщ)

No atiendo por MP nada que no sea personal.
  #3 (permalink)  
Antiguo 02/01/2011, 13:13
 
Fecha de Ingreso: junio-2006
Ubicación: España
Mensajes: 122
Antigüedad: 13 años, 6 meses
Puntos: 2
Respuesta: Problema de tildes con botón "me gusta" facebook

pues es como lo tenía al principio, pero al subir la página al servidor no me funcionaban las tildes, entonces tube que ponerlo comolo tengo para que me vayan.
  #4 (permalink)  
Antiguo 02/01/2011, 13:24
Avatar de pateketrueke
Modernizr
 
Fecha de Ingreso: abril-2008
Ubicación: Mexihco-Tenochtitlan
Mensajes: 26.399
Antigüedad: 11 años, 8 meses
Puntos: 2534
Respuesta: Problema de tildes con botón "me gusta" facebook

deberías usar UTF-8 que es el estándar, además de esa forma es que funcionan bien utf8_encode/decode

¿entonces ya has resuelto tu problema?
__________________
Y U NO RTFM? щ(ºдºщ)

No atiendo por MP nada que no sea personal.
  #5 (permalink)  
Antiguo 02/01/2011, 14:03
 
Fecha de Ingreso: junio-2006
Ubicación: España
Mensajes: 122
Antigüedad: 13 años, 6 meses
Puntos: 2
Respuesta: Problema de tildes con botón "me gusta" facebook

en su día toque eso porque las noticias que recogía de la base de datos que tenían tildes, salian dibujos como rombos negros en vez de la vocal con tilde.

La cosa es que ahora funciona... y no toqué nada

Gracias!
  #6 (permalink)  
Antiguo 02/01/2011, 15:22
 
Fecha de Ingreso: junio-2006
Ubicación: España
Mensajes: 122
Antigüedad: 13 años, 6 meses
Puntos: 2
Respuesta: Problema de tildes con botón "me gusta" facebook

Bueno vuelvo a escribir por desgracia, no entiendo muy que pasa, algunos articulos que comparto (que llevan tilde) me lo hace perfectamente, y en cambio otros (con tilde tambien) me salen mal, otra cosa que me pasa es que en algunos no me sale ninguna imagen (cuando comparto), cuando todos, todos tienen una.

uso estas metaetiquetas

<meta property="og:title" content="<?php echo htmlentities($nombre); ?>"/>
<meta property="og:site_name" content="nombredemipagina"/>
<meta property="og:image" content="<?php echo $foto; ?>"/>
<link rel="image_src" href="<?php echo $foto; ?>" />

En que se basa el botón compartir para poner el nombre al articulo a compartir? y la imagen? de donde la recoje si hay algunos que no van...

Gracias.
  #7 (permalink)  
Antiguo 14/07/2011, 13:19
 
Fecha de Ingreso: agosto-2009
Mensajes: 72
Antigüedad: 10 años, 4 meses
Puntos: 2
Respuesta: Problema de tildes con botón "me gusta" facebook

Cita:
Iniciado por lmerli Ver Mensaje
Bueno vuelvo a escribir por desgracia, no entiendo muy que pasa, algunos articulos que comparto (que llevan tilde) me lo hace perfectamente, y en cambio otros (con tilde tambien) me salen mal, otra cosa que me pasa es que en algunos no me sale ninguna imagen (cuando comparto), cuando todos, todos tienen una.

uso estas metaetiquetas

<meta property="og:title" content="<?php echo htmlentities($nombre); ?>"/>
<meta property="og:site_name" content="nombredemipagina"/>
<meta property="og:image" content="<?php echo $foto; ?>"/>
<link rel="image_src" href="<?php echo $foto; ?>" />

En que se basa el botón compartir para poner el nombre al articulo a compartir? y la imagen? de donde la recoje si hay algunos que no van...

Gracias.

Muy buena pregunta! alguien sabe??

Etiquetas: facebook, tildes
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 12:22.