Foros del Web » Programando para Internet » PHP »

Problema urgente! No se me ven las imagenes!

Estas en el tema de Problema urgente! No se me ven las imagenes! en el foro de PHP en Foros del Web. Hola a todos, les explico mi problema tengo una pagina con una imagen y la guardo como HTML y anda de maravilla pero cuando la ...
  #1 (permalink)  
Antiguo 26/08/2007, 09:45
Avatar de manumaf  
Fecha de Ingreso: mayo-2007
Ubicación: Argentina
Mensajes: 853
Antigüedad: 12 años, 9 meses
Puntos: 6
Problema urgente! No se me ven las imagenes!

Hola a todos, les explico mi problema tengo una pagina con una imagen y la guardo como HTML y anda de maravilla pero cuando la guardo en .php la imagen no se me ve mas y necesito que sea php la pagina no entiendo por que no se ve la imagen y me pasa con todas las paginas no solo con esa
Acá les dejo un poco de código

Código HTML:
 <td height="60" colspan="2" valign="top" bordercolor="EE9800" bgcolor="#FFE763"><img src="title.gif" width="330" height="47" /></td> 
Es solo una imagen llamada title.gif dentro de una celda y no me aprese la imagen.

Por fabor tengo que terminar rapido esta web y no puedo arreglar esto.
  #2 (permalink)  
Antiguo 26/08/2007, 09:56
Avatar de shakaran  
Fecha de Ingreso: agosto-2005
Ubicación: España - Ciudad Real
Mensajes: 374
Antigüedad: 14 años, 6 meses
Puntos: 7
Re: Problema urgente! No se me ven las imagenes!

Esto no es parece problema de php si no de rutas de archivo en html.

Estas seguro que la imagen esta con la ruta correcta?
__________________
Quijost Backend Engineer - www.quijost.com - Hosting rápido, eficiente y profesional
Blog: www.shakaran.net
  #3 (permalink)  
Antiguo 26/08/2007, 10:02
Avatar de manumaf  
Fecha de Ingreso: mayo-2007
Ubicación: Argentina
Mensajes: 853
Antigüedad: 12 años, 9 meses
Puntos: 6
Re: Problema urgente! No se me ven las imagenes!

No ya me di cuenta que es pero no puedo solucionarlo por que la pagina php sola si anda pero yo tengo en index con el siguiente código dentro de una celda

Código PHP:
                        <?php
$id 
$_GET['id'];  
switch(
$id){

case 
'panel=2':
include(
"hom/qs.php");
break;

case 
'panel=3':
include(
"hom/contact.php");
break;

case 
'panel=4':
include(
"hom/links.php");
break;

case 
'panel=5':
include(
"dgrafic/imghabbo/imghabbo.php");
break;

default:
include(
"hom/home.php");
break;

}
?>
Que es para los vínculos. Cuando carga alguna de esas paginas dentro de la celda aparece todo menos las imágenes por que es eso?

Si yo por ejemplo entro directamente a la pagina php me aprese la imagen pero cuando se carga dentro de la celda no me aparece, estoy desesperado!
  #4 (permalink)  
Antiguo 26/08/2007, 10:51
Avatar de Seppo  
Fecha de Ingreso: marzo-2005
Ubicación: Buenos Aires, Argentina
Mensajes: 1.284
Antigüedad: 14 años, 11 meses
Puntos: 17
Re: Problema urgente! No se me ven las imagenes!

El problema es la ruta que toma HTML. Si vos entrás directamente a una subcarpeta se toma la ruta desde esa subcarpeta, si entrás desde el directorio base se toma desde ese directorio... La solución más fácil es que utilices una ruta absoluta (por ejemplo, http://www.example.com/imagenes/pic.jpg) para la imagen, y de esa forma no va a depender desde que directorio se busca a la imagen.
  #5 (permalink)  
Antiguo 26/08/2007, 11:44
Avatar de manumaf  
Fecha de Ingreso: mayo-2007
Ubicación: Argentina
Mensajes: 853
Antigüedad: 12 años, 9 meses
Puntos: 6
Re: Problema urgente! No se me ven las imagenes!

Gracias ahora me funciona!

Saludos!
  #6 (permalink)  
Antiguo 19/12/2007, 12:47
 
Fecha de Ingreso: diciembre-2007
Mensajes: 1
Antigüedad: 12 años, 2 meses
Puntos: 0
Re: Problema urgente! No se me ven las imagenes!

Entoces significa que el include no sirve para reflejar bloques dentro de otras carpetas?
como se hace para reflejar bloques con php?
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 06:44.