Foros del Web » Programando para Internet » PHP »

problema xml con php

Estas en el tema de problema xml con php en el foro de PHP en Foros del Web. Estoy tratando de generar un resultado en xml, pero cuando lo veo en el explorador, el codigo fuente lo muestra bien formado, pero en la ...
  #1 (permalink)  
Antiguo 12/10/2007, 09:43
Avatar de moron  
Fecha de Ingreso: mayo-2004
Mensajes: 972
Antigüedad: 15 años, 9 meses
Puntos: 2
problema xml con php

Estoy tratando de generar un resultado en xml, pero cuando lo veo en el explorador, el codigo fuente lo muestra bien formado, pero en la pantalla me muestra los datos, pero no en el formato de arbol, sino uno al lado del otro

este es el codigo:

<?echo '<' ; ?>?xml version="1.0" encoding="ISO-8859-1"?>
<?
echo "<estiquetas>";
foreach ($object->Get_Lista() as $Lista)
{
echo "<etiqueta>";
echo "<etNombre>". $Lista->_get("nombre")."</etNombre>";
echo "<etUbicacion>". $Lista->_get("ubicacion")."</etUbicacion>";
echo "<etRespon>". $Lista->_get("responsable")."</etRespon>";
echo "</etiqueta>";
}

echo "</etiquetas>";



este es el xml resultante:

<?xml version="1.0" encoding="ISO-8859-1"?>
<etiquetas>
<etiqueta>
<etNombre>nombre</etNombre>
<etUbicacion>aca</etUbicacion>
<etRespon>Daniel</etRespon>
</etiqueta>
<etiqueta>
<etNombre>etiquetaMan</etNombre>
<etUbicacion>Cor</etUbicacion>
<etRespon>Pepe</etRespon>
</etiqueta>
</etiquetas>


alguna idea de lo que puede ser?
  #2 (permalink)  
Antiguo 12/10/2007, 13:18
Avatar de Marvin
Colaborador
 
Fecha de Ingreso: febrero-2005
Ubicación: global $Chile->Santiago;
Mensajes: 1.990
Antigüedad: 15 años
Puntos: 80
Re: problema xml con php

En tu codigo pusiste echo "<estiquetas>"; y deberia ser echo "<etiquetas>"; sin la S.

Suerte!
__________________
El que dice "Solo sé que nada sé", esta asumiendo que sabe algo.
Lea las FAQ's!
  #3 (permalink)  
Antiguo 12/10/2007, 13:35
Avatar de moron  
Fecha de Ingreso: mayo-2004
Mensajes: 972
Antigüedad: 15 años, 9 meses
Puntos: 2
Re: problema xml con php

en realidad era que me faltaba

Header ("Content-type: text/xml" );

muchas gracias Marvin.

saludos
  #4 (permalink)  
Antiguo 12/10/2007, 13:42
Avatar de Marvin
Colaborador
 
Fecha de Ingreso: febrero-2005
Ubicación: global $Chile->Santiago;
Mensajes: 1.990
Antigüedad: 15 años
Puntos: 80
Re: problema xml con php

Ahh okales... pense que habias pegado el codigo tal como venia :P

Suerte! :D
__________________
El que dice "Solo sé que nada sé", esta asumiendo que sabe algo.
Lea las FAQ's!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:12.