Foros del Web » Programando para Internet » PHP »

problemas con codigo

Estas en el tema de problemas con codigo en el foro de PHP en Foros del Web. Buenas gente, les comento: tengo un problema con la visualizacion de imagenes, paso los scripts y comento el problema: Código PHP: <?php      mysql_connect ( "localhost" ...
  #1 (permalink)  
Antiguo 05/12/2004, 14:12
 
Fecha de Ingreso: agosto-2003
Ubicación: comodoro rivadavia
Mensajes: 74
Antigüedad: 14 años, 3 meses
Puntos: 0
Exclamación problemas con codigo

Buenas gente, les comento: tengo un problema con la visualizacion de imagenes, paso los scripts y comento el problema:

Código PHP:
<?php 
    mysql_connect
("localhost","root","") or die ("no se ha podido conectar a la BD"); 

    
mysql_select_db("test") or die ("no se ha podido seleccionar la BD"); 
     
    
$sql "SELECT id,size,path,nombre FROM pics"
    
$consulta mysql_query($sql) or die ("No se pudo ejecutar la consulta");
    
        While (
$registro=mysql_fetch_assoc($consulta)){
        
        echo 
"<img src='".$registro['path']."' width="100" height="100" border="0">"
           echo 
"<br> Nombre archivo: ".$registro['nombre']; 
        echo 
"<br> Peso: ".$registro['size']." bytes.<br><br>"
    } 

?>

Este scripts es el que supuestamente me tiene que mostrar las imagenes, si saco la linea de "img src", me muestra el nombre del archivo y tamaño, que esta a continuacion, pero si coloco la linea no muestra nada.
Cual puede ser el problema
En la vase de datos como dice guardo datos como: Nombre, tamaño, path, etc.....
__________________
NO QUIERAS LO QUE NO TIENES, QUIERE LO QUE TIENES.

Última edición por mechinity; 05/12/2004 a las 14:35 Razón: Porque nadie responde
  #2 (permalink)  
Antiguo 05/12/2004, 15:21
Avatar de Nefertiter  
Fecha de Ingreso: enero-2003
Ubicación: Rosario
Mensajes: 1.316
Antigüedad: 14 años, 11 meses
Puntos: 8
fijate en la linea
echo "<img src='".$registro['path']."' width="100" height="100" border="0">";

si queres que los tamaños salgan con 100 tenes que escribir asi

echo "<img src='".$registro['path']."' width=\"100\" height=\"100\" border=\"0\">";

sino tira error de escape de number y no se otras cosas
por lo demas deberia estar bien, se te ejecuta en igual cantidad que registros en tenes en la tabla?
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:40.