Foros del Web » Programando para Internet » PHP »

Problemas con el editor de PHP

Estas en el tema de Problemas con el editor de PHP en el foro de PHP en Foros del Web. Hola: Estoy buscando un editor de PHP que tenga debug, o sea un buen depurador que me permita ejecutar paso a paso las instrucciones de ...
  #1 (permalink)  
Antiguo 14/04/2006, 03:34
 
Fecha de Ingreso: abril-2004
Ubicación: Palma de Mallorca
Mensajes: 24
Antigüedad: 13 años, 8 meses
Puntos: 0
Problemas con el editor de PHP

Hola: Estoy buscando un editor de PHP que tenga debug, o sea un buen depurador que me permita ejecutar paso a paso las instrucciones de un script de PHP.

He probado muchos. Los que más me convencen son el Maguma y el Zend Studio. Pero con los dos tengo el mismo problema: No conectan con el gestor de bases de datos MySQL que es el que se usa comunmente con PHP. Ni siquiera leen la instrucción mysqlconnect().

Alguien sabe cómo puedo solucionar el problema. De que manera puedo decirle al editor en donde tengo el MySQL para que trabaje con el.

Gracias.

Tomàs
  #2 (permalink)  
Antiguo 14/04/2006, 15:44
Avatar de Shevkorn  
Fecha de Ingreso: enero-2005
Ubicación: Trujillo
Mensajes: 34
Antigüedad: 12 años, 11 meses
Puntos: 1
Usaste el PHPEdit ???, a mi me funciona de las 1000 maravillas, ahora que si el detalles esta en que debes bajartelo con su key y todo... solucion:Buscate un buen programa P2P y busca alguno que tenga key
Saludos
Taek
__________________
Taek said: ¿Aùn los pecadores podremos llegar al cielo?
  #3 (permalink)  
Antiguo 17/04/2006, 08:47
 
Fecha de Ingreso: abril-2004
Ubicación: Palma de Mallorca
Mensajes: 24
Antigüedad: 13 años, 8 meses
Puntos: 0
No me funciona el PHP edit

El PHPedit tiene buena pinta pero no he logrado ejecutar ningun script. El error que me da es "Session start timeout has expired" y no hay manera. He probado con varias versiones del programa y nada.

He consultado una FAQ y me dice que situe la libreria de debug php_dbg.dll en la carpeta correspondiente de extensiopnes para evitar el error. La he colocado y sigue igual. Yo creo que la libreria que tengo no se corresponde con la version del PHP y no sé en donde conseguir las librerias correspondientes a cada versión del PHP. ¿Sabes algo al respecto?.
  #4 (permalink)  
Antiguo 17/04/2006, 11:00
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
El depurador DBG debugger (http://dd.cron.ru/dbg/) tiene dos componentes:
1) Una extensión para PHP (del lado del servidor)
2) Un módulo para el IDE que uses (del lado del "cliente", muchos IDE's lo incorporan de serie).

La extensión para PHP ha de ser exactamente la de la versión de PHP que uses (no la que pueda llevar la versión de tu IDE favorito que la incluyese). En el sitio oficial de DBG Debugger tienes pre-compiladas para windows las .dll de la versión de PHP que soporten a la fecha. Si no ves ahí la de la versión de PHP que uses, no uses cualquiera, busca otro depurador.

La extensión en sí .. si usas windows (PHP bajo windows) debes instalarla como otra extensión cualquiera, es decir . .mover tu php_dbg.dll hacia el directorio /extensions y habilitar o crear la entrada en tu php.ini que apunte a dicha extensión: extension = php_dbg.dll

La parte "cliente" .. será el IDE que uses y su documentación como tienes que hacerlo.

Otro IDE que podrías usar que enlaza con DBG debugger es:

Maguma
www.maguma.com

Y si quieres algo ya integrado todo en una (PHP + IDE + Depurador y herramientas) y tienes $$$$ puedes ver:

Zend Studio
www.zend.com

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
  #5 (permalink)  
Antiguo 19/04/2006, 09:33
 
Fecha de Ingreso: abril-2004
Ubicación: Palma de Mallorca
Mensajes: 24
Antigüedad: 13 años, 8 meses
Puntos: 0
Sigo con problemas

Que raro no?
¿Como es pòsible que instales un editor y simplemente no funcione sin más?.

He hecho todos los cambios de configuración y no funciona. Ahora el problema es un mensaje de error que sale nada más ejecutar un script y que es: "Function registration failed duplicate name". . Supongo que a ti no te ha salido pero quizás es que el Apache y el MySql que tienes instalados son distintos a los mios.

Como a mi el MySQL no se me instala bien (no sé porqué) he instalado el paquete Appserv que es el que he usado hasta ahora. Contiene el Apache, el PHP y el MySql. Pero con el editor PHPedit me ha dado los errores que te he referido.

¿Cómo tienes tu tu configuracion? ¿Tienes alguna posible solución al error que te he relatado?

Gracias por tu atención
  #6 (permalink)  
Antiguo 19/04/2006, 10:59
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Ahora no uso PHP bajo windows .. pero en su momento usé DBG debugger con Maguma y PHP bajo windows. La única precaución fué la de usar la extensión de DBG Debugger (esa php_xxx.dll) exacta a la versión de PHP que usaba.

¿Tu has instalado la extensión de DBG debugger a tu versión de PHP y quedó correctamente (haciendo un phpinfo() lo puedes verificar).?

Empieza por ahí si quieres usar ese depurador .. Luego usa o buscate el IDE que mas te guste que enlace con DBG Debugger y sigue sus instrucciones de uso. Presta atención a las versiones que uses de PHP y las que vas a usar de DBG Debugger.

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 11:26.