Foros del Web » Programando para Internet » PHP »

problemas con extensions

Estas en el tema de problemas con extensions en el foro de PHP en Foros del Web. hola: Hasta el momento no me afectan para nada, pero siempre que inicia apache me lanza errores con las extensions, algo asi como Unable to ...
  #1 (permalink)  
Antiguo 12/11/2003, 09:53
Avatar de claudiovega  
Fecha de Ingreso: octubre-2003
Ubicación: Puerto Montt
Mensajes: 3.667
Antigüedad: 14 años, 1 mes
Puntos: 11
problemas con extensions

hola:

Hasta el momento no me afectan para nada, pero siempre que inicia apache me lanza errores con las extensions, algo asi como Unable to Load php_interbase.dll, por ejemplo.

Yo uso Apache,Php y Mysql sobre Windows Xp.
Tengo en el php.ini, en la linea extension_dir lo siguiente:

extension_dir=c:/php/extensions/

Todas las dll estan ahi, asi que nose a que se debe. Ademas, nose si estoy en lo correcto, pero si no puede cargar la dll no podria usar ciertas cosas, como por ejemplo conectarme con sql server, sin embargo lo puedo hacer, y no via ODBC, sino con las funciones mssql_connect por ejemplo. Una explicación que podria darle (muy probable de estar equivocada, pues no lo se bien) es que a pesar de no cargar la libreria al "levantar" apache, la carga cuando se hace una peticion de una funcion que está en alguna de ellas, por algo son dinamicas no?
bueno, esta es mi consulta, por que pasa esto y como se soluciona?
  #2 (permalink)  
Antiguo 12/11/2003, 20:42
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Las librerias "dinámicas" se levantan con la funcón dl() .. si lo haces desde tu php.ini (con las directivas extension=php_xxx.dll) se "levantan" cuando lo hace Apache (si PHP está como módulo de Apache).

Muchas extensiones requieren de más librerias (.dll) parar poder trabajar. No sé si será el caso de las de Interbase .. pero por si acaso puedes verlo en PHP.net:

http://www.php.net/manual/en/install...sions.overview


Si te fijas .. dice:
php_interbase: "Requires: gds32.dll (bundled)"

Supongo que será parte de Interbase .. lo mismo que si usas con normalidad tus mssql_xxx() funciones es por qué ya tienes instalado SQL server ahí ...

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
  #3 (permalink)  
Antiguo 13/11/2003, 07:25
Avatar de claudiovega  
Fecha de Ingreso: octubre-2003
Ubicación: Puerto Montt
Mensajes: 3.667
Antigüedad: 14 años, 1 mes
Puntos: 11
Gracias cluster, igual pensandolo bien si se cargan al momento de levantar apache, es mejor no levantarlas por que consumirian muchos recursos, o no? y dejar comentadas todas las lineas de dll que no utilice, pues yo solo uso mysql y he realizado unas pruebas con sql server para "ver si funciona". Viendo las dll que hay en el directorio extensions me parece que, para mis fines actuales, no necesito ninguna de ellas y por lo tanto podria comentarlas todas.
Aparte, hay otro directorio llamado dlls, en el cual si esta la libreria gds32.dll que me decias y revisando el error es:

unknown(): Unload dynamic library xxxxx.dll . No se puede encontrar el modulo especificado.

por lo que no sería lo de la libreria gds32.dll.

¿Tu que tienes mas experiencia que yo, que librerias, de las que son parte de extensions, recomendarias como para mantenerlas activas? y bueno, aun no se porque no se cargan.
__________________
Dedicado a proyectos web, actualmente desarrollando un sistema de diseño de flyers online muy fácil de usar.
  #4 (permalink)  
Antiguo 16/11/2003, 11:38
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Ese directorio con tus librerias .dll (el directorio dll ) debes moverlo a tu windows/system (sólo los .dll).. ahí donde están no tienen efecto para PHP y las otras php_xxxx.dll que las puedan usar (por ejemplo las referentes a XML están ahí y hay que moverlas a tu windows/sytem)

Sobre los recursos de tus librerias .. Si habitualmente usas las librerias GD .. cargalas al incio de Apache (configurando tu php.ini ya que usas PHP como módulo )

En general .. usa las que necesiten tus aplicaciones .. Yo no habilito "todas" las extensiones .. sino las que use.. y muchas veces me doy cuenta con un error tipo "no está definida tal función" si es que ando probando scripts .. ahí veo que hace falta habilitar tal extension .. y la habilito.

Algunas técnicas de programación usan estructuras tipo .. IF (está cargada la extensión) .. continuo . .else .. la cargo con dl("extension .."). Pero eso no lo hacen todas las aplicaciones .. así que estate antento a mensajes de error como los que comenté sobre tal función no existe que suele ser eso.

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.

Última edición por Cluster; 16/11/2003 a las 11:39
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 08:25.