Foros del Web » Programando para Internet » PHP »

Problemas con la funcion mail();

Estas en el tema de Problemas con la funcion mail(); en el foro de PHP en Foros del Web. Saludos ForosdelWeb, Tengo un pequeño problema aunque para mi es bastante grande. Tengo el Apache 1.3 server instaslado con un servidor de cuentas de correo ...
  #1 (permalink)  
Antiguo 16/12/2003, 05:18
Avatar de syntex  
Fecha de Ingreso: noviembre-2002
Ubicación: Cataluña
Mensajes: 978
Antigüedad: 15 años, 1 mes
Puntos: 4
Problemas con la funcion mail();

Saludos ForosdelWeb,

Tengo un pequeño problema aunque para mi es bastante grande.

Tengo el Apache 1.3 server instaslado con un servidor de cuentas de correo Argosoft mail y bueno me funciona cuando quiere porque tengo envios de correo que me funcionan sin ningun problema y despues le pongo:

<? if (mail("[email protected]","hola","hola")){echo"Cor recto";} ?>

pues no me lo envia no se si es algun error de PHP.INI

Estaria muy agradecido si alguien me pudiese hechar una mano ya que no me se ocurre nada de nada,

Saludos
__________________
------------------------------------------------
La paciencia es el rey de la ciencia
------------------------------------------------

  #2 (permalink)  
Antiguo 16/12/2003, 05:38
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 5 meses
Puntos: 16
Hola,

Sobre la configuracion del php.ini, puedes mirar http://www.forosdelweb.com/showthrea...498#post328498 .

Lo que pasa es que no te entiendo con lo que dices "tengo envios de correo que me funcionan " ¿envios desde PHP? ¿o con otro programa?

Y tampoco defines "no me lo envia " ¿no te muestra el mensaje "Correcto"? ¿o si te lo muestra pero no te llega al buzon de destino?

Suerte.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
  #3 (permalink)  
Antiguo 16/12/2003, 05:46
Avatar de syntex  
Fecha de Ingreso: noviembre-2002
Ubicación: Cataluña
Mensajes: 978
Antigüedad: 15 años, 1 mes
Puntos: 4
Es que es muy raro el problema porque me lo envia habeces.
__________________
------------------------------------------------
La paciencia es el rey de la ciencia
------------------------------------------------

  #4 (permalink)  
Antiguo 16/12/2003, 05:50
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 5 meses
Puntos: 16
¿Te envia a veces (te muestra el mensaje "Correcto" a veces)? ¿O te llega el email a veces (siempre te muestra el mensaje pero no te llega siempre al buzon)? Si es esto ultimo, ¿es siempre con la misma direccion, o es a direcciones distintas (como @hotmail.com, ...)?
__________________
Josemi

Aprendiz de mucho, maestro de poco.
  #5 (permalink)  
Antiguo 16/12/2003, 05:51
Avatar de syntex  
Fecha de Ingreso: noviembre-2002
Ubicación: Cataluña
Mensajes: 978
Antigüedad: 15 años, 1 mes
Puntos: 4
Siempre me pone que ha sido enviado correctamente pero no me llega el correo.

Saludos
__________________
------------------------------------------------
La paciencia es el rey de la ciencia
------------------------------------------------

  #6 (permalink)  
Antiguo 16/12/2003, 05:52
Avatar de syntex  
Fecha de Ingreso: noviembre-2002
Ubicación: Cataluña
Mensajes: 978
Antigüedad: 15 años, 1 mes
Puntos: 4
siempre es a la misma cuenta de correo [email protected]
__________________
------------------------------------------------
La paciencia es el rey de la ciencia
------------------------------------------------

  #7 (permalink)  
Antiguo 16/12/2003, 05:54
Avatar de FireBytes  
Fecha de Ingreso: enero-2002
Ubicación: Irun | Guipuzcoa | España
Mensajes: 131
Antigüedad: 15 años, 11 meses
Puntos: 0
Prueba a poner TODOS los parametros de
Código PHP:
mail("$destino","$asunto","$texto","From:$remitente"
. Algunos servidores de SMTP requieren que $remitente sea un e-mail. En otros casos se puede usar cualquier texto (como From:WebMailerDeMiSite por ejemplo xD)
__________________
By FireBytes © 2003

http://www.asis-online.org/images/minibanner.gif
  #8 (permalink)  
Antiguo 16/12/2003, 05:56
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 5 meses
Puntos: 16
¿Y que te dicen los logs del servidor de correo? Porque si mail() devuelve true (y te muestra el mensaje) es que ha tenido exito al pasar el mensaje a tu servidor SMTP (el argosoft tuyo). Luego puede ser que el servidor SMTP, por x o por y, no logre mandar el mensaje al servidor SMTP destino (en tu caso hotmail).

Saludos.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
  #9 (permalink)  
Antiguo 16/12/2003, 05:56
Avatar de syntex  
Fecha de Ingreso: noviembre-2002
Ubicación: Cataluña
Mensajes: 978
Antigüedad: 15 años, 1 mes
Puntos: 4
me pone que si a sido enviado pero no e recibido nada

if (mail("[email protected]","hola","texto","From:remit ente")){echo"s";}
__________________
------------------------------------------------
La paciencia es el rey de la ciencia
------------------------------------------------

  #10 (permalink)  
Antiguo 16/12/2003, 05:59
Avatar de syntex  
Fecha de Ingreso: noviembre-2002
Ubicación: Cataluña
Mensajes: 978
Antigüedad: 15 años, 1 mes
Puntos: 4
Tengo tambien el norton antivirus y veo que el mensaje se esta enviando pero es raro que no me llege a la cuenta, ya que desde outlook express envio el mensaje y me super rápido.

Voy a ver los logs del argosoft mail server 1.8.x.x
__________________
------------------------------------------------
La paciencia es el rey de la ciencia
------------------------------------------------

  #11 (permalink)  
Antiguo 16/12/2003, 05:59
Avatar de syntex  
Fecha de Ingreso: noviembre-2002
Ubicación: Cataluña
Mensajes: 978
Antigüedad: 15 años, 1 mes
Puntos: 4
No tengo ningun archivo .log en argosoft email
__________________
------------------------------------------------
La paciencia es el rey de la ciencia
------------------------------------------------

  #12 (permalink)  
Antiguo 16/12/2003, 06:05
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 5 meses
Puntos: 16
Esto, supongo que te estaras asegurando de que no es que los emails tarden en aparecer en Hotmail. Mas que nada porque si el norton te indica que el email esta saliendo de tu equipo. Ahora mismo creo que los emails tardan en llegar al Hotmail.

Quizas ahora te empiezan llegar todos los mensajes retrasados.

Y no tengo ni idea del argosoft, pero deberia tener alguna opcion. Los logs son fundamentales para cualquier servidor.

Suerte.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
  #13 (permalink)  
Antiguo 16/12/2003, 06:07
Avatar de syntex  
Fecha de Ingreso: noviembre-2002
Ubicación: Cataluña
Mensajes: 978
Antigüedad: 15 años, 1 mes
Puntos: 4
Ahora le e creado el archivo log

16/12/2003 12:06:33 - Requested SMTP connection from 80.xx.xx.xx [80.xx.xx.xx]
16/12/2003 12:06:33 - ( 24) 220 80.xx.xx.xx ArGoSoft Mail Server Pro for WinNT/2000/XP, Version 1.8 (1.8.2.2)
16/12/2003 12:06:33 - ( 24) HELO mercadillo
16/12/2003 12:06:33 - ( 24) 250 Welcome, 80.xx.xx.xx[80.xx.xx.xx], pleased to meet you
16/12/2003 12:06:33 - ( 24) MAIL FROM:<80.xx.xx.xx>
16/12/2003 12:06:33 - ( 24) 250 Sender "80.xx.xx.xx" OK...
16/12/2003 12:06:33 - ( 24) RCPT TO:<[email protected]>
16/12/2003 12:06:34 - ( 24) 250 Recipient "[email protected]" OK...
16/12/2003 12:06:34 - ( 24) DATA
16/12/2003 12:06:34 - ( 24) 354 Enter mail, end with "." on a line by itself
16/12/2003 12:06:34 - ( 24) Received 123 bytes
16/12/2003 12:06:34 - [ 25] Delivering to [email protected]
16/12/2003 12:06:34 - [ 25] Attempting to deliver to the domain hotmail.com
16/12/2003 12:06:34 - ( 24) 250 Message accepted for delivery. <[email protected]>
16/12/2003 12:06:34 - ( 24) QUIT
16/12/2003 12:06:34 - ( 24) 221 Aba he
16/12/2003 12:06:34 - SMTP connection with 80.xx.xx.xx [80.xx.xx.xx] ended. ID=24
16/12/2003 12:06:34 - [ 25] Retrieved 4 MX records for domain hotmail.com
16/12/2003 12:06:34 - [ 25] Trying the server mx4.hotmail.com.: 65.54.167.230
16/12/2003 12:06:34 - [ 25] 220 mc12-f17.hotmail.com Microsoft ESMTP MAIL Service, Version: 5.0.2195.6713 ready at Tue, 16 Dec 2003 03:06:36 -0800
16/12/2003 12:06:34 - [ 25] EHLO 80.xx.xx.xx
16/12/2003 12:06:35 - [ 25] 250-mc12-f17.hotmail.com (02.04.01.0012) Hello [80.xx.xx.xx]
16/12/2003 12:06:35 - [ 25] 250-SIZE 29696000
16/12/2003 12:06:35 - [ 25] 250-PIPELINING
16/12/2003 12:06:35 - [ 25] 250-8bitmime
16/12/2003 12:06:35 - [ 25] 250-BINARYMIME
16/12/2003 12:06:35 - [ 25] 250-CHUNKING
16/12/2003 12:06:35 - [ 25] 250-VRFY
16/12/2003 12:06:35 - [ 25] 250-AUTH LOGIN
16/12/2003 12:06:35 - [ 25] 250-AUTH=LOGIN
16/12/2003 12:06:35 - [ 25] 250-X-HMAUTH
16/12/2003 12:06:35 - [ 25] 250 OK
16/12/2003 12:06:35 - [ 25] MAIL FROM:<80.xx.xx.xx>
16/12/2003 12:06:35 - [ 25] 250 [email protected]....Sender OK
16/12/2003 12:06:35 - [ 25] RCPT TO:<[email protected]>
16/12/2003 12:06:35 - [ 25] 250 [email protected]
16/12/2003 12:06:35 - [ 25] DATA
16/12/2003 12:06:35 - [ 25] 354 Please start mail input.
16/12/2003 12:06:35 - [ 25]
16/12/2003 12:06:35 - [ 25] .
16/12/2003 12:06:35 - [ 25] 250 Mail queued for delivery.
16/12/2003 12:06:35 - [ 25] QUIT
16/12/2003 12:06:36 - [ 25] 221 Closing connection. Good bye.
16/12/2003 12:06:36 - [ 25] Message from 80.xx.xx.xx
relayed to the domain hotmail.com
16/12/2003 12:06:43 - Server is running
__________________
------------------------------------------------
La paciencia es el rey de la ciencia
------------------------------------------------

  #14 (permalink)  
Antiguo 16/12/2003, 06:08
Avatar de syntex  
Fecha de Ingreso: noviembre-2002
Ubicación: Cataluña
Mensajes: 978
Antigüedad: 15 años, 1 mes
Puntos: 4
Ya llevo tres dias esperando.

Saludos
__________________
------------------------------------------------
La paciencia es el rey de la ciencia
------------------------------------------------

  #15 (permalink)  
Antiguo 16/12/2003, 06:18
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 5 meses
Puntos: 16
Pues ese mensaje del que pones el log se supone que deberia haber llegado, ya que muestra el dialogo entre tu servidor y el de hotmail. Y parece que el de hotmail lo acepta. Sera cuestion de ver el log de un envio que no llegue. Porque no creo que sea un filtro antispam de hotmail, porque si fuese eso bloquearia todos.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
  #16 (permalink)  
Antiguo 16/12/2003, 06:21
Avatar de syntex  
Fecha de Ingreso: noviembre-2002
Ubicación: Cataluña
Mensajes: 978
Antigüedad: 15 años, 1 mes
Puntos: 4
Lo que si lo tengo puesto en el puerto 26 porque si le pongo el puerto 25 es como si mo lo hubieran bombardeado me comienza a sacar emails pero a montones y no lo puedo parar ya que lo tengo en el puerto 26.
__________________
------------------------------------------------
La paciencia es el rey de la ciencia
------------------------------------------------

  #17 (permalink)  
Antiguo 16/12/2003, 07:04
Avatar de FireBytes  
Fecha de Ingreso: enero-2002
Ubicación: Irun | Guipuzcoa | España
Mensajes: 131
Antigüedad: 15 años, 11 meses
Puntos: 0
Cita:
Mensaje Original por syntex
Ya llevo tres dias esperando.
La paciencia es el rey de la ciencia
__________________
By FireBytes © 2003

http://www.asis-online.org/images/minibanner.gif
  #18 (permalink)  
Antiguo 16/12/2003, 07:11
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 5 meses
Puntos: 16
Bueno, a mi hermano le llego un email semanas despues de ser enviado. Para que luego nos quejemos de correos.

¿Te llego el mensaje que se envio y quedo registrado en el log? Es por estas cosas (y los filtros antispam) por los que odio a hotmail. Y otra cosa que odio son los errores "intermitentes" como este. Al final no sabes que es lo que lo causa, y simplemente pones a parir a guillermito puertas.

Saludos.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
  #19 (permalink)  
Antiguo 16/12/2003, 13:00
Avatar de syntex  
Fecha de Ingreso: noviembre-2002
Ubicación: Cataluña
Mensajes: 978
Antigüedad: 15 años, 1 mes
Puntos: 4
Saludos ForosdelWeb

He resuelto el problema ya que era una variable con los codigod de html

$R = "
<html>
<head>
<title></title>
</head>
<body>
";
$R .= "texto";
$R .= "</body></html>";

mail("[email protected]","asunto",$R);

Saludos a todos
__________________
------------------------------------------------
La paciencia es el rey de la ciencia
------------------------------------------------

  #20 (permalink)  
Antiguo 12/01/2004, 09:37
Avatar de syntex  
Fecha de Ingreso: noviembre-2002
Ubicación: Cataluña
Mensajes: 978
Antigüedad: 15 años, 1 mes
Puntos: 4
Saludos ForosdelWeb.

Creo que me va fatal no me llegan

Conoceis algun tipo smtp y pop que sea estable??

Yo utilizo el Argosoft mail con una ip fija
__________________
------------------------------------------------
La paciencia es el rey de la ciencia
------------------------------------------------

Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 07:38.