Foros del Web » Programando para Internet » PHP »

problemas con la función mail() </table ??

Estas en el tema de problemas con la función mail() </table ?? en el foro de PHP en Foros del Web. Tengo un problema a la hora de usar la función mail() de php. Tengo una variable $contenido en la que voy concatenando el código HTML ...
  #1 (permalink)  
Antiguo 25/10/2004, 13:22
 
Fecha de Ingreso: octubre-2004
Mensajes: 21
Antigüedad: 13 años, 1 mes
Puntos: 0
problemas con la función mail() </table ??

Tengo un problema a la hora de usar la función mail() de php.

Tengo una variable $contenido en la que voy concatenando el código HTML de la siguiente forma:

$contenido = "<table....>";
$contenido .= "<td...>";
..
hasta el final donde cierro la tabla:

$contenido .= "</table>";

Recibo todo bien e interpreta correctamente el código HTML, pero dentro del mail me muesta como texto:

</table

Alguien sabe que me puede estar pasando?

Estas son las cabeceras que uso y la llamada a la funcion mail():

$header = "From:[email protected]\nReply-To:[email protected]\n";
$header .= "X-Mailer:PHP/".phpversion()."\n";
$header .= "Mime-Version: 1.0\n";
$header .= "Content-type: text/html; charset=iso-8859-1\r\n";

mail($mymail, $subject, utf8_decode($contenido) ,$header);
  #2 (permalink)  
Antiguo 25/10/2004, 13:56
 
Fecha de Ingreso: octubre-2004
Mensajes: 21
Antigüedad: 13 años, 1 mes
Puntos: 0
He cerrado el último contenido con:

$contenido .= "</table>>";


y funciona,... no le encuentro la explicación lógica de añadir otro ">". Si alguien la tiene?
Gracias,
J.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 02:46.