Foros del Web » Programando para Internet » PHP »

problemas con get y post

Estas en el tema de problemas con get y post en el foro de PHP en Foros del Web. tengo una aplicacion que corre bajo windows y tengo apache como servidor pero ahora tengo que ponerla en linux y apache, el problema es que ...
  #1 (permalink)  
Antiguo 21/07/2004, 16:24
 
Fecha de Ingreso: mayo-2004
Mensajes: 10
Antigüedad: 13 años, 7 meses
Puntos: 0
problemas con get y post

tengo una aplicacion que corre bajo windows y tengo apache como servidor
pero ahora tengo que ponerla en linux y apache, el problema es que cuando la diseñe para windows en las paginas que reciben los datos por medio de get o post nunca puse $_GET[] o $_POST, sea el caso, para recibir las variables, y me funcionaba perfectamente, ahora cuando lo quiser poner en linux el valor de las variables no los pasa y parece que tengo que poner $_GET o $_Post sera por algun problema de configuracion en linux , apache o php que estan instalados en linux
  #2 (permalink)  
Antiguo 21/07/2004, 16:31
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
El cómo puedas recibir tus variables externas lo define la configuración de PHP:

(php.ini)
register_globals

pero .. tal cual lo usa tu servidor Linux .. es lo ideal .. Lee esta FAQ y adapta tus aplicaciones .. así podrás migrar tus aplicaciones a servidores con configuración register_globals a ON o a OFF sin problemas .. además que si usas register_globals a OFF serán más seguras tus aplicaciones:

http://www.forosdelweb.com/showthrea...989#post238989

Un saludo,
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 00:57.