Foros del Web » Programando para Internet » PHP »

Problemas con IFRAME

Estas en el tema de Problemas con IFRAME en el foro de PHP en Foros del Web. Dispongo de un formulario para realizar pedidos (index.php), desde ahi hago un llamado a una rutina llamada subpedir.php detallada a continuación: <? //Coneccion a base ...
  #1 (permalink)  
Antiguo 08/05/2006, 17:04
 
Fecha de Ingreso: octubre-2005
Mensajes: 405
Antigüedad: 12 años, 1 mes
Puntos: 1
Problemas con IFRAME

Dispongo de un formulario para realizar pedidos (index.php), desde ahi hago un llamado a una rutina llamada subpedir.php detallada a continuación:

<?
//Coneccion a base de dato
include("../conexion.php");
?>
<html>
<head>
<title>Formulario de Pedido</title>
<META HTTP-EQUIV="Pragma" CONTENT="no-cache">
<style type="text/css">
<!--
input { font-family: Tahoma, Verdana, Arial; font-size: 11px; color: #000000; background-color: #CCCCCC; border: 1px #000000 solid}
select { font-family: Tahoma, Verdana, Arial; font-size: 11px; color: #FFFFFF; background-color: #6699CC; border: #000099; border-style: solid; border-top-width: 1px; border-right-width: 1px; border-bottom-width: 1px; border-left-width: 1px}
-->
</style>
</head>
<body bgcolor=0099FF>

<form method=POST action='subpedir.php'>
<table border=0 align=center>
<tr>
<td width=46%>
<div align=center><font color=FFFFFF size=1 face=Verdana, Arial, Helvetica, sans-serif><b>Producto</b></font></div>
</td>
<td width=24%>
<div align=center><font color=FFFFFF size=1 face=Verdana, Arial, Helvetica, sans-serif><b>Marca</b></font></div>
</td>
<td width=16%>
<div align=center><font color=FFFFFF size=1 face=Verdana, Arial, Helvetica, sans-serif><b>Cantidad</b></font></div>
</td>
<td rowspan=2 valign=middle align=center>
<input type=submit name=Submit value=Agregar>
</td>
</tr>
<tr>
<td width=46% align=center valign=middle>
<select size=1 name=desc maxlength=100>
<option selected>Selecciona Producto</option>
<?
$sql="select * from insumos";
$res=mysql_query($sql,$conectar) or die(mysql_error());
while($reg=mysql_fetch_array($res))
{
$cod=$reg['codigo_i'];
$nom=$reg['nombre_i'];
echo "<option value=$codigo>$nom</option>";
echo $codigo;
}
?>
</select>
</td>
<td width=24% align=center valign=middle>
<input type=text name=marca size=25>
</td>
<td width=16% valign=middle align=center>
<input type=text name=cantidad size=7>
</td>
</tr>
</table>
<br>
</form>

<table width=483 border=1 cellpadding=0 cellspacing=0 bgcolor=00cccc align=center>
<tr>
<td align=center width='40'><font size=1 face=Verdana, Arial, Helvetica, sans-serif color=ffffff><b>&nbsp;&nbsp;&nbsp;Código</b></font></td>
<td align=center width='145'><font size=1 face=Verdana, Arial, Helvetica, sans-serif color=ffffff><b>Descripción</b></font></td>
<td align=center width='100'><font size=1 face=Verdana, Arial, Helvetica, sans-serif color=ffffff><b>Marca</b></font></td>
<td align=center width='40'><font size=1 face=Verdana, Arial, Helvetica, sans-serif color=ffffff><b>&nbsp;&nbsp;Cantidad</b></font></td>
<tr>
<td colspan=4>
<iframe src="subpedirlistar.php" scrolling=true frameborder=0 width=100% height=150 framecolor=ffffea></iframe>
</td>
</tr>
</table>
</body>
</html>

mi problema es el siguiente en el iframe destacado realizo un llamado a subpedirlistar.php el cual deberia mostrar los datos ingresados en subpedir ($codigo, $nombre, marca y cantidad), dentro del iframe el cual no recupera los datos.
Es esa la razón por la cual me contacto con ustedes.
Espero tener pronta respuesta desde ya les saluda atte. Germán.

en caso que les sirva
subpedirlistar.php
<?
$codigo=$_Post['codigo'];
$desc=$_Post['desc'];
$marca=$_Post['marca'];
$cantidad=$_Post['cantidad'];
echo $codigo;
echo $desc;
echo $marca;
echo $cantidad;
?>
  #2 (permalink)  
Antiguo 08/05/2006, 17:33
Avatar de emiliodeg  
Fecha de Ingreso: septiembre-2005
Ubicación: Córdoba
Mensajes: 1.830
Antigüedad: 12 años, 3 meses
Puntos: 54
bueno desde el vamos aca hay un error
while($reg=mysql_fetch_array($res))
{
$cod=$reg['codigo_i'];
$nom=$reg['nombre_i'];
echo "<option value=$codigo>$nom</option>";
echo $codigo;
}
deberias cambiar $codigo por $cod

segundo en el subpedirlistar.php
$codigo=$_Post['codigo'];
$desc=$_Post['desc'];
$marca=$_Post['marca'];
$cantidad=$_Post['cantidad'];
en ningun lugar veo q aparezcan des marca y cantidad solo pones el cod

el array $_Post[] no se escribe asi, es $_POST[]

los selects q generas tienen todos el mismo nombre, agregale <select size="1" name="desc[]" maxlength="100"> con el [] vas a hacer q php lo tome como un array y segundo trata de usar "" para los valores q asignas pq esto no siempre funciona bien y mucho menos funciona bien en todos los browsers

y dentro del subpedirlistar.php deberias tener algo asi
for($i=0;$i<count($_POST['desc']);$i++){
echo $_POST['desc'][$i];//listado de codigos con los cuales podrias hacer la busqueda y listar los productos selecionardos
}
espero q te sirva
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 21:32.