Foros del Web » Programando para Internet » PHP »

Problemas con imagenes subidas al servidor...

Estas en el tema de Problemas con imagenes subidas al servidor... en el foro de PHP en Foros del Web. Holas... Tengo un problema, tengo un script para subir imagenes al servidor y me funciona a la perfeccion pero el problema es cuando trato de ...
  #1 (permalink)  
Antiguo 20/06/2006, 18:50
 
Fecha de Ingreso: junio-2006
Ubicación: Antofagasta
Mensajes: 216
Antigüedad: 11 años, 6 meses
Puntos: 7
Problemas con imagenes subidas al servidor...

Holas...
Tengo un problema, tengo un script para subir imagenes al servidor y me funciona a la perfeccion pero el problema es cuando trato de acceder a la foto desde la URL, por ejemplo si quiero verla en w ww.servidor.com/fotos/foto1.jpg me sale que no tengo el permiso suficiente para poder verla,

Código:
403

Forbidden
You don't have permission to access /fotos/foto1.jpg on this server.
lo mismo me pasa si intento incluir esa foto en una pagina por medio de <img src...>
Si entro al panel de control del servidor que uso (pandela.com) reviso en la carpeta que almacena las fotos y estas no me aparecen con los permisos necesarios con lo cual tengo que darselos yo manualmente.
Ahora lo que yo quiero es que al subir la foto desde el scrip, automaicamente me la deje con los permisos necesarios para ser visualizada por cualquier usuario, como se hace eso??, mi problema es problema de script o de configuracion del servidor??
si alguien puede ayudarme y orientarme estaria agradecido.
  #2 (permalink)  
Antiguo 21/06/2006, 00:12
 
Fecha de Ingreso: enero-2006
Ubicación: Buenos Aires, Argentina
Mensajes: 299
Antigüedad: 11 años, 11 meses
Puntos: 5
Buenas, podrías probar usando chmod() en el script que sube el archivo al servidor (o sea, una vez que lo subís, asignás los permisos correspondientes).

Acá se explica, probablemente necesites darles permiso 0644
http://ar.php.net/es/chmod

Personalmente, no tengo mucha experiencia con chmod(), ya que nunca me pasó que al subir archivos quedaran con permiso 0. Lo cual me lleva a pensar que seguramente debe poderse establecer en la configuración del servidor determinados permisos por defecto, para el caso de que no se especifiquen. O sea que el tema podría encararse desde el lado del script o del server. Pero tal vez chmod() te alcance para solucionar el problema.

Suerte
Califa
  #3 (permalink)  
Antiguo 21/06/2006, 09:36
 
Fecha de Ingreso: junio-2006
Ubicación: Antofagasta
Mensajes: 216
Antigüedad: 11 años, 6 meses
Puntos: 7
Muchas gracias CALIFA, probare usando chmod() en el script y te comento como me fue.
  #4 (permalink)  
Antiguo 21/06/2006, 19:22
 
Fecha de Ingreso: junio-2006
Ubicación: Antofagasta
Mensajes: 216
Antigüedad: 11 años, 6 meses
Puntos: 7
muchas gracias por la ayuda, probe colocando chmod() y me resulta bien, ahora puedo subir las fotos y me cambia los permisos.

Gracias por la ayuda.
  #5 (permalink)  
Antiguo 23/06/2006, 05:58
 
Fecha de Ingreso: mayo-2005
Ubicación: Murcia
Mensajes: 319
Antigüedad: 12 años, 7 meses
Puntos: 0
Codigo De Tu Script

Greco2, por favor podrías poner el codigo que tienes para ver si me sirve...?

Gracias
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:24.