Foros del Web » Programando para Internet » PHP »

Problemas con las sesiones.

Estas en el tema de Problemas con las sesiones. en el foro de PHP en Foros del Web. Hola, a ver si me podeis ayudar a resolver este Expediente X. Os explico, yo tengo mi página de inicio en la que valido al ...
  #1 (permalink)  
Antiguo 26/08/2005, 08:04
Avatar de Ay0
Ay0
 
Fecha de Ingreso: enero-2002
Ubicación: Tenerife
Mensajes: 66
Antigüedad: 15 años, 11 meses
Puntos: 0
Pregunta Problemas con las sesiones.

Hola, a ver si me podeis ayudar a resolver este Expediente X.

Os explico, yo tengo mi página de inicio en la que valido al usuario, éste pasa a otra página en la que hago otras validaciones y luego, ésta llama a otra que contiene un frame. Pues bien, el paso de la penúltima página a la última (la que contiene el frame), sólo en unos PC's, parece perder la sesión en la una las dos páginas que contiene el frame, en donde yo guardo el usuario que ha entrado a la aplicación. La página del frame, si reciber perfectamente la sesión, pero las que están contenidas en él, parecen perderla.

La última comprobación que he hecho es ver el session_id(), a ver si eran diferentes y por eso estaba vacía la sesión, pero los números son iguales.

¿A alguien le ha pasado algo parecido?

Agredecería muchísimo alguna idea.

Saludos.
  #2 (permalink)  
Antiguo 29/08/2005, 03:28
Avatar de Ay0
Ay0
 
Fecha de Ingreso: enero-2002
Ubicación: Tenerife
Mensajes: 66
Antigüedad: 15 años, 11 meses
Puntos: 0
Pues va a ser que a nadie le ha ocurrido esto no? Ya decía yo que esto era un Expediente X.
  #3 (permalink)  
Antiguo 06/09/2005, 10:33
 
Fecha de Ingreso: agosto-2005
Mensajes: 76
Antigüedad: 12 años, 4 meses
Puntos: 0
Hola,

He escrito este post, con mi problema con las sesiones y la autenticacion con apache,

http://www.forosdelweb.com/f18/autenticacion-http-apache-junto-sesion-php-331175/

y al leer tu post he de decir que mi index.html consite en un frame y en un main... el formulario que me da error, esta dentro del frame (en main).

No es mucha ayuda, pero quiza esten relacionados ambos problemas. Si tienes alguna pista de como solucionarlo, te agradecería que la escribieras por aqui. Un saludo.
  #4 (permalink)  
Antiguo 06/09/2005, 10:44
 
Fecha de Ingreso: julio-2004
Mensajes: 61
Antigüedad: 13 años, 4 meses
Puntos: 0
acordate q antes de cualkier cosa tenes q poner


session_start()


esto va en todas las paigans... tmb en la de los frames

salu2
=P
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 12:00.