Foros del Web » Programando para Internet » PHP »

problemas con las variables de sistema

Estas en el tema de problemas con las variables de sistema en el foro de PHP en Foros del Web. resulta que si utilizo el phpinfo() me dice que al utilizar la variable de sistema REQUEST_URI me deberia entregar como resultado lo siguiente = /admin.php?module=Mant_tom&op=mainplay... ...
  #1 (permalink)  
Antiguo 13/11/2003, 14:45
 
Fecha de Ingreso: septiembre-2003
Mensajes: 6
Antigüedad: 14 años, 3 meses
Puntos: 0
problemas con las variables de sistema

resulta que si utilizo el phpinfo() me dice que al utilizar la variable de sistema REQUEST_URI me deberia entregar como resultado lo siguiente = /admin.php?module=Mant_tom&op=mainplay...

pero al ejecutar esa variable en mi codigo solo aparece lo siguiente = /admin.php

alguien sabe por que ocurre esto????

Gracias
  #2 (permalink)  
Antiguo 13/11/2003, 16:55
 
Fecha de Ingreso: septiembre-2003
Mensajes: 6
Antigüedad: 14 años, 3 meses
Puntos: 0
ya encontre la solucion.....habia que colocar la funcion getenv antes....ej


$id= getenv("REQUEST_URI ");

ahi logro hacerla aparecer en pantalla....

gracias a los que leyeron por lo menos
  #3 (permalink)  
Antiguo 16/11/2003, 12:15
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Usar getenv() depende de la instalación de tu PHP bajo tu servidor HTTP ..

Con $_SERVER['REQUEST_URI'] si usas PHP bajo Módulo de Apache también puedes accede a esas variables (PHP 4.1.0 en adelante e independiente el estado de register_globals de tu php.ini ..)

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 00:33.