Foros del Web » Programando para Internet » PHP »

Problemas con mail

Estas en el tema de Problemas con mail en el foro de PHP en Foros del Web. Tengo el siguiente codigo: <? $destinatario = "[email protected]"; $asunto = "Este mensaje es de prueba"; $cuerpo = ' <html> <head> <title>Prueba de correo</title> </head> <body> ...
  #1 (permalink)  
Antiguo 01/06/2005, 05:32
Avatar de Pandora  
Fecha de Ingreso: mayo-2005
Mensajes: 17
Antigüedad: 12 años, 6 meses
Puntos: 0
Pregunta Problemas con mail

Tengo el siguiente codigo:
<?
$destinatario = "[email protected]";
$asunto = "Este mensaje es de prueba";
$cuerpo = '
<html>
<head>
<title>Prueba de correo</title>
</head>
<body>
<h1>Hola!</h1>
<p>
<b>Bienvenidos a mi correo electrónico de prueba</b>.
Esto es una prueba de un correo en formato html.
</p>
</body>
</html>
';

$headers = "MIME-Version: 1.0\r\n";
$headers .= "Content-type: text/html; charset=iso-8859-1\r\n";

$headers .= "From: Ivan <[email protected]>\r\n";

$headers .= "Reply-To: [email protected]\r\n";

$headers .= "Return-path: [email protected]\r\n";

mail($destinatario,$asunto,$cuerpo,$headers);
?>
<HTML>
<HEAD>
<TITLE>Prueba Mail</TITLE>

</HEAD>

<BODY>
Se supone que tiene que llegar este mail
</BODY>

</HTML>


y me sale el siguiente error:

Warning: mail() [function.mail]: SMTP server response: 553 We do not relay non-local mail, sorry. in C:\wwwroot\ppp2\pruebamail.php on line 28
Tengo funcionando Mercury (el de xampp), no se que le puede pasar?????
En php.ini tengo:
[mail function]
; For Win32 only.
SMTP = localhost
smtp_port = 25

; For Win32 only.
sendmail_from = [email protected]
Estoy desesperadita! Tengo que configurar algo en Mercury?
  #2 (permalink)  
Antiguo 01/06/2005, 07:20
Avatar de gustavoang  
Fecha de Ingreso: julio-2003
Ubicación: Valencia - Venezuela
Mensajes: 253
Antigüedad: 14 años, 4 meses
Puntos: 1
Hola.

Estoy seguro que el problema no es de PHP, por lo que pienso que deberías publicar éste mensaje en el foro de los servidores Web.

Si no consigues alguna respuesta en Foros del Web, te recomiendo que busques alguna comunidad de Xampp o directamente una de Mercury... Primero intenta con la de Xampp porque puede ser algo específico de esa distribución.

Saludos.
__________________
Gustavo Narea.
Venezuela.
  #3 (permalink)  
Antiguo 01/06/2005, 08:13
Avatar de maralbust  
Fecha de Ingreso: febrero-2004
Ubicación: Santiago
Mensajes: 578
Antigüedad: 13 años, 9 meses
Puntos: 0
creo a mi ver por el error es que el servidor no tiene ningun tipo de stmp server, si quieres probar, puedes bajar el minirelay, es un programilla bastante util para hacer pruebas de smtp.


saludos
__________________
..:: NADA SE PIERDE SOLO SE TRANSFORMA ::..
  #4 (permalink)  
Antiguo 02/06/2005, 01:41
Avatar de Pandora  
Fecha de Ingreso: mayo-2005
Mensajes: 17
Antigüedad: 12 años, 6 meses
Puntos: 0
Muchas Gracias. Trataré de usar el minirelay. Y si no funciona me pasaré al foro de servidores Web
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:53.