Foros del Web » Programando para Internet » PHP »

Problemas con mail

Estas en el tema de Problemas con mail en el foro de PHP en Foros del Web. tengo el siguiente codigo para el envio de mail: $header = "MIME-Version: 1.0\r\n"; $header .= "Content-type: text/html; charset=iso-8859-1\r \n"; $header .= "From: SBS <".$email.">\n"; mail($to[0],$titulo,$mensaje,$header); ...
  #1 (permalink)  
Antiguo 11/04/2006, 14:44
 
Fecha de Ingreso: septiembre-2003
Mensajes: 265
Antigüedad: 14 años, 2 meses
Puntos: 1
Pregunta Problemas con mail

tengo el siguiente codigo para el envio de mail:

$header = "MIME-Version: 1.0\r\n";
$header .= "Content-type: text/html; charset=iso-8859-1\r \n";
$header .= "From: SBS <".$email.">\n";

mail($to[0],$titulo,$mensaje,$header);

no tengo ningun problema al mandar el mail, lo unico que cuando me lo mando a mi cuenta de yahooy de de hotmail, el html sale perfecto, pero cuando me lo mando al de gmail solo me aparece el codigo del html y no me lo convierte.
  #2 (permalink)  
Antiguo 11/04/2006, 15:32
Avatar de mauled  
Fecha de Ingreso: marzo-2005
Ubicación: Cd. de México.
Mensajes: 3.001
Antigüedad: 12 años, 9 meses
Puntos: 33
Te pido de favor que chehttp://www.forosdelweb.com/showthrea...350#post254350ques este link
  #3 (permalink)  
Antiguo 11/04/2006, 16:14
Avatar de JAK^  
Fecha de Ingreso: octubre-2005
Ubicación: ^^CaMiNiTo Al CoSTaDo DeL
Mensajes: 850
Antigüedad: 12 años, 1 mes
Puntos: 4
De acuerdo proba asi

hola como estas? mira yo tenia un problem similar fijate si te sirve esto

Código PHP:
$para=$myrow[e_mail];
    
$tema="Este es el Tema";
    
$autor"Este es el Autor";
    
$autor_mail="[email protected]";
    
$cabeceras  'MIME-Version: 1.0' "\r\n";
    
$cabeceras .= 'Content-type: text/html; charset=iso-8859-1' "\r\n";
    
$cabeceras .="From: ".$autor."<".$autor_mail.">\nReply-To:".$autor_mail."\nX-Mailer: PHP/"phpversion();
    
$mensaje='<html>
                            <body>
                                 .
                                 .
                                 .
                            </body>
                            </html>'
;
if (@
mail ($para$tema$mensaje$cabeceras)) { 
       echo 
"bien!!!!!!!";

}
else { 
       echo 
"mal";

ami asi me funciona perfecto espero ke te sirva...suerte!!!

salu2
  #4 (permalink)  
Antiguo 11/04/2006, 16:37
 
Fecha de Ingreso: septiembre-2003
Mensajes: 265
Antigüedad: 14 años, 2 meses
Puntos: 1
una consulta....................influye si el servidor desde donde estoy mandanlo los mail, esta como spam (el servidor)????????????????????????????

Última edición por bisteck; 11/04/2006 a las 16:51
  #5 (permalink)  
Antiguo 11/04/2006, 16:43
Avatar de JAK^  
Fecha de Ingreso: octubre-2005
Ubicación: ^^CaMiNiTo Al CoSTaDo DeL
Mensajes: 850
Antigüedad: 12 años, 1 mes
Puntos: 4
mil perdones!!!! en la primera linea ke dice
<php BEGIN__VBULLETIN__CODE__SNIPPET $para=$myrow[e_mail];

ahy va en $para el mail del destinatario ej $para="[email protected]";

asi tal kual lo tengo yop y me anda perfectamente saludos...
  #6 (permalink)  
Antiguo 11/04/2006, 16:57
 
Fecha de Ingreso: septiembre-2003
Mensajes: 265
Antigüedad: 14 años, 2 meses
Puntos: 1
Pregunta

Cita:
Iniciado por JAK^
mil perdones!!!! en la primera linea ke dice
<php BEGIN__VBULLETIN__CODE__SNIPPET $para=$myrow[e_mail];

ahy va en $para el mail del destinatario ej $para="[email protected]";

asi tal kual lo tengo yop y me anda perfectamente saludos...


JAK

Hola

los mail llegan sin ningun problema, pero cuando los mando a mi cuenta de gmail soslo me aparce el codigo html

ejemplo:
Content-type: text/html; charset=iso-8859-1

From: SBS <[email protected]>
Reply-To: [email protected]
X-Mailer: PHP/4.3.10

<div align="center"><p><a .........................

esto solo aparece cuando lo mando a la cuenta de gmail

¿una duda esa linea que dice?

<php BEGIN__VBULLETIN__CODE__SNIPPET .....

debo colocar??

y lo otro si el servidor desde donde estoy manadando los mail esta en la lista de spam, esto influye

mil gracias JAK
  #7 (permalink)  
Antiguo 11/04/2006, 17:33
Avatar de JAK^  
Fecha de Ingreso: octubre-2005
Ubicación: ^^CaMiNiTo Al CoSTaDo DeL
Mensajes: 850
Antigüedad: 12 años, 1 mes
Puntos: 4
ke raro

la linea esa no la tenes ke poner so te agrega el editor del foro kuando remarkas codigos php
Código PHP:
//esa linea la pone el editor 
ves

mira lo del tema del server no kreo ke tenga ke ver te deberia reportar como spam y nada mas lo ke si fijate si en tu kuenta tenes habilitada las propiedades de ver correo html o solo texto plano ¿alguna ves te llego un mail html a esa kuenta de otro emisor?
no se me okurre nada mas la verdad ke ami me anda bien no se ke mas podra ser el problem

salu2
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:22.