Foros del Web » Programando para Internet » PHP »

problemas con mi gestor de noticias...

Estas en el tema de problemas con mi gestor de noticias... en el foro de PHP en Foros del Web. tengo un gestor de noticias que tiene el siguiente error: cuando publico una noticia larga la tabla se deforma y crese hacia los lados en ...
  #1 (permalink)  
Antiguo 24/03/2003, 16:57
 
Fecha de Ingreso: diciembre-2002
Ubicación: en mi casa
Mensajes: 131
Antigüedad: 15 años
Puntos: 0
problemas con mi gestor de noticias...

tengo un gestor de noticias que tiene el siguiente error:
cuando publico una noticia larga la tabla se deforma y crese hacia los lados en vez de crecer para abajo.
http://legendz.hispanet.com/okai.jpg
este es un ejemplo.
aqui les dejo el codigo
Código PHP:
$codigo="<table width='487' border='1' cellpadding='10' cellspacing='0' bordercolor='#000000' background='tablefondo.gif' bgcolor='#C3DEFC' style='border-collapse: collapse'><tr><td><table width='437' border='0' cellpadding='0' cellspacing='0' bordercolor='#C3DEFC'><tr><td><p style='margin-left: 8'><font face='Arial' size='2'>$Tema<br>Noticia enviada el $fecha</font><font face='Arial' style='font-size: 11pt'><br></font><font face='Arial' size='2'>Por: $user_name</font></td><td width='25%' bgcolor='#C3DEFC'><p align='center'> <img src='img/usuarios/$user_name.gif' border='0'></td></tr><tr><td width='100%' colspan='2' bgcolor='#C3DEFC'><hr color='#000000' align='center' width='90%' noshade size='1'><p style='margin-left: 8'><font face='Arial' size='2'> $mensaje<br>&nbsp;</font></td></tr></td></tr></table></tr></table><br>"
  #2 (permalink)  
Antiguo 24/03/2003, 17:05
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Tambien le pasa a estos foros xD... .En PHP podrías usar:

wordwrap()
http://www.php.net/manual/en/function.wordwrap.php

Y en HTML seguro que hay alguna solución .. tal vez usando tamaños fijos de tus tablas en pixels .. no usando "nowarp" .. etc .. Pretuntalo en el foro HTML ..

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
  #3 (permalink)  
Antiguo 26/03/2003, 17:52
 
Fecha de Ingreso: diciembre-2002
Ubicación: en mi casa
Mensajes: 131
Antigüedad: 15 años
Puntos: 0
no funciona... habra ayuda algun metodo HTML??
  #4 (permalink)  
Antiguo 26/03/2003, 20:29
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
wordwrap() debería funcionar .. osese, si le indicas X caracteres que "parta" el string de origen y q el salto de línea sea <br> .. te debería ir ..

Por el ejemplo que usas .. igual no lo estas usando bien ..

Sobre soluciones HTML .. ya te dije que mejor si preguntas en su foro dedicado al HTML .. tal vez algun "<tag>" por ahí o forma de definir tus tablas HTML puedan solucionar tu problema ..

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:00.