Foros del Web » Programando para Internet » PHP »

Problemas con mi web modulas tipo index.php?id=6?foto=11

Estas en el tema de Problemas con mi web modulas tipo index.php?id=6?foto=11 en el foro de PHP en Foros del Web. Estimados, estoy trabanjo en mi web... Está funcionando modularmente... Código: <? $id=$_GET['id']; switch ($id) { case 1: include("info.php"); break; case 2: include("familia.php"); break; case 6: ...
  #1 (permalink)  
Antiguo 06/09/2004, 19:10
Avatar de El_MiMo  
Fecha de Ingreso: septiembre-2003
Ubicación: Chile
Mensajes: 123
Antigüedad: 14 años, 3 meses
Puntos: 1
Problemas con mi web modulas tipo index.php?id=6?foto=11

Estimados, estoy trabanjo en mi web...
Está funcionando modularmente...
Código:
<? 
$id=$_GET['id']; 
switch ($id) 
{ 
 case 1: include("info.php");       break; 
 case 2: include("familia.php");    break;
 case 6: include("blog.php");       break; 
default: include("home1.php"); 
} 
?>
Y los links dentro de la web funcionan perfectamente con sus modulos.

El problema, es que tengo un flog... que toma una info desde una base de datos...

Código:
 <?php
$link = mysql_connect("localhost","usuario","password");
mysql_select_db ("base_de_datos", $link) OR die ("Error: No es posible conectar con la base de datos.");
$query = mysql_query("SELECT * FROM flog ORDER BY id DESC LIMIT 0,5");
while($row = mysql_fetch_array($query)){
echo "
<p><font color=#FFFFFF size=2 face=verdana><strong>$row[titulo]</strong></font><br>
<font color=#CCCCCC size=1 face=verdana>($row[fecha])<br>
<a href=index.php?id=6?foto=$row[id]>
<img src='fotos/th/$row[foto]' border='0'></font></a></p>
";
}
mysql_close($link);
?>
<a href=index.php?id=6?foto=$row[id]>
Pero al ingresar a esa dirección, no me muestra el contenido...

En cambio, si entro directamente a blog.php?foto=$row[id] funciona.

Alguien me pueda hechar una manito???

Gracias.
__________________
aaa!!
  #2 (permalink)  
Antiguo 06/09/2004, 20:08
 
Fecha de Ingreso: junio-2004
Mensajes: 101
Antigüedad: 13 años, 6 meses
Puntos: 0
Hola:

Creo que deberias repasar bien esto

Código PHP:
<a href=index.php?id=6?foto=$row[id]> 
Cuado deberia ser asi:


Código PHP:
<a href=index.php?id=6&foto=$row[id]> 

Creo que debes empesar por solucionar eso.....


Saludos
  #3 (permalink)  
Antiguo 06/09/2004, 20:52
Avatar de El_MiMo  
Fecha de Ingreso: septiembre-2003
Ubicación: Chile
Mensajes: 123
Antigüedad: 14 años, 3 meses
Puntos: 1
:o
Muchas gracias Sig..
ese era el problema.....

Todos los días se aprende algo nuevo.
__________________
aaa!!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 02:22.