Foros del Web » Programando para Internet » PHP »

Problemas con la ñ en XML DOM

Estas en el tema de Problemas con la ñ en XML DOM en el foro de PHP en Foros del Web. El problema es que al recoger el contenido de un XML a traves de un XML DOM de php no me recoge las ñ y ...
  #1 (permalink)  
Antiguo 24/02/2006, 02:44
 
Fecha de Ingreso: febrero-2006
Mensajes: 3
Antigüedad: 11 años, 10 meses
Puntos: 0
Exclamación Problemas con la ñ en XML DOM

El problema es que al recoger el contenido de un XML a traves de un XML DOM de php no me recoge las ñ y me lo cambia por Ñ.

Alguien me puede ayudar a solucionar
  #2 (permalink)  
Antiguo 24/02/2006, 03:10
Avatar de FuLaNo_  
Fecha de Ingreso: mayo-2003
Ubicación: Don Torcuato, Buenos Aires, Argentina
Mensajes: 1.250
Antigüedad: 14 años, 6 meses
Puntos: 2
Debe ser un problema de encoding...

No es la solución, pero podrías probar aplicandole la funcion urlencode() al texto, esto hace que te develva caracteres especiales para ser interpretados correctamente en una URL, algo que tambien "lee" bien el navegador... por ejemplo el espacio lo cambia a %20... (hola%20mundo) y así con letras especiales (ñ, ó, í, á, â, etc)

Como dije, no es la solucion correcta, pero si lo necesitas "ya" creo que te servirá.

Estoy seguro que el problema es que tenes el encoding del XML en utf (unicode) o similar..
__________________
I Love Programming...
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:04.