Foros del Web » Programando para Internet » PHP »

problemas con php

Estas en el tema de problemas con php en el foro de PHP en Foros del Web. tengo un problema al querer accesar a auna base de datos ya que me marca un error al coectarme a ella el erro exacto es ...
  #1 (permalink)  
Antiguo 27/12/2004, 17:52
Avatar de makrack  
Fecha de Ingreso: septiembre-2004
Ubicación: Mexico
Mensajes: 64
Antigüedad: 13 años, 3 meses
Puntos: 0
problemas con php

tengo un problema al querer accesar a auna base de datos ya que me marca un error al coectarme a ella

el erro exacto es Fatal Error: Call to undefined function mysql_connect() in guardado.php on line 52


Porfavor ayudenme

Última edición por makrack; 27/12/2004 a las 18:01
  #2 (permalink)  
Antiguo 27/12/2004, 17:59
Avatar de baklao  
Fecha de Ingreso: noviembre-2004
Ubicación: Santa Ana - Isla de Margarita
Mensajes: 482
Antigüedad: 13 años
Puntos: 0
Hola q tal
corrije la sintaxis de mysql_conecct()
por
mysql_conect()

Salu2.

Bye
__________________
Atte. Mohamed :aplauso:
  #3 (permalink)  
Antiguo 27/12/2004, 18:03
Avatar de makrack  
Fecha de Ingreso: septiembre-2004
Ubicación: Mexico
Mensajes: 64
Antigüedad: 13 años, 3 meses
Puntos: 0
perdon me equivoque

ups la sintaxis correcta es mysql_connect()


pero aun asi me marca el mismo error que sera


¡¡¡¡¡¡¡¡¡¡AYUDENME !!!!!!!!!!!!!!!!!!!
  #4 (permalink)  
Antiguo 27/12/2004, 19:33
Avatar de lado2mx
Colaborador
 
Fecha de Ingreso: agosto-2001
Ubicación: Veracruz
Mensajes: 3.720
Antigüedad: 16 años, 4 meses
Puntos: 9
que versión de PHP estás usando?
  #5 (permalink)  
Antiguo 28/12/2004, 00:45
Avatar de dmedina83  
Fecha de Ingreso: mayo-2004
Ubicación: Mérida
Mensajes: 96
Antigüedad: 13 años, 6 meses
Puntos: 0
Tienes instalado el mysql?
__________________
WebAdictos - Una dosis diaria de web
  #6 (permalink)  
Antiguo 28/12/2004, 05:24
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Parece que usas PHP 5.x y Mysql versión ????

En PHP 5 el soporte para Mysql no viene por defecto instalado (como lo es para PHP 4) .. hay que instalar la extensión y librería de Mysql que uses (en función de la versión de Mysql que uses).

Busca en el foro .. ese tema se ha tratado ampliamente, pero lo ideal es que aclares que versión de PHP y de Mysql usas!.

Un saludo,
  #7 (permalink)  
Antiguo 28/12/2004, 06:01
 
Fecha de Ingreso: marzo-2003
Ubicación: onde toy?
Mensajes: 1.437
Antigüedad: 14 años, 9 meses
Puntos: 9
trata de cambiar todas tus funciones que sean mysql por mysqli de seguro estás trabajando con php 5 por eso te ocurre el error.. ojo que debes consultar la documentación en www.php.net porque las nuevas funciones mysqli_ tiene pequeñas variaciones con las mysql_
__________________
Buena Vida...
Francisco
  #8 (permalink)  
Antiguo 28/12/2004, 07:17
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Igualmente uses el nuevo soporte del nuevo cliente para Mysql de PHP 5 (mysqli_xxx()) o PHP 4 (mysql_xxx()) requieres instalar/habilitar las extensiones correspondientes .. de hecho si usas PHP 5 puedes usar las dos y así ir migrando tus viejas aplicaciones hacia el nuevo cliente de Mysql para PHP 5.

Un saludo,
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 08:44.