Foros del Web » Programando para Internet » PHP »

Problemas con PHP5 y extensiones

Estas en el tema de Problemas con PHP5 y extensiones en el foro de PHP en Foros del Web. Cuando trato de habilitar extensiones descargadas desde snaps.php.net con PHP5 me da este error: Cita: PHP Startup: cvsclient : Unable to initialize module Module compiled ...
  #1 (permalink)  
Antiguo 29/03/2005, 08:03
Avatar de Reynier  
Fecha de Ingreso: noviembre-2002
Ubicación: Por ahí en algún sitio
Mensajes: 1.844
Antigüedad: 15 años
Puntos: 1
Problemas con PHP5 y extensiones

Cuando trato de habilitar extensiones descargadas desde snaps.php.net con PHP5 me da este error:
Cita:
PHP Startup: cvsclient : Unable to initialize module
Module compiled with module API=20040412, debug=0, thread-safety=1
PHP compiled with module API=20041030, debug=0, thread-safety=1
These options need to match
que es esto? como puedo solucionar mi problema?

Salu2
__________________
Ing. Reynier Pérez Mira
  #2 (permalink)  
Antiguo 29/03/2005, 08:45
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
El mensaje te dice que estás usando extensiones que no son compiladas para la versión de PHP que usas exacta .. No puedes usar extensiones que tomes de aquí y de allá .. deben ser compiladas (si usas windows sobre todo) para la versión concreta y exacta que usas de PHP. Buscalas para la versión que uses.

Un saludo,
  #3 (permalink)  
Antiguo 29/03/2005, 09:13
Avatar de Reynier  
Fecha de Ingreso: noviembre-2002
Ubicación: Por ahí en algún sitio
Mensajes: 1.844
Antigüedad: 15 años
Puntos: 1
Y ...

Como se la version que uso y de donde debo bajar esas extensiones. Tengo la última versión de PHP5 bajada desde snaps.php.net y de ahi mismo me he bajado las extensiones.

Salu2
__________________
Ing. Reynier Pérez Mira
  #4 (permalink)  
Antiguo 29/03/2005, 09:54
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
La versión que usas exactamente la puedes ver haciendo un:

<?
phpinfo();
?>

Los "snaps" son las versiones "al día" de PHP en desarrollo ..

Lo ideal es que uses siempre la versión estable de PHP (4 o 5) de:
http://www.php.net/downloads.php

El paquete .zip (si hablamos de windows) . contiene todas las extensiones hasta la fecha estables que puedes usar y compiladas para esa versión concreta de PHP.

Un saludo,
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 11:15.