Foros del Web » Programando para Internet » PHP »

problemas con tildes

Estas en el tema de problemas con tildes en el foro de PHP en Foros del Web. Hola, En una página que estoy haciendo por tontear ( Cuirosas ) he instalado un script en php para sindicar noticias en rss (rdf, xml). ...
  #1 (permalink)  
Antiguo 12/11/2003, 13:06
 
Fecha de Ingreso: noviembre-2003
Mensajes: 51
Antigüedad: 14 años, 1 mes
Puntos: 0
problemas con tildes

Hola,

En una página que estoy haciendo por tontear (Cuirosas) he instalado un script en php para sindicar noticias en rss (rdf, xml). Lo hace a la perfección, pero hay un pequeño problemilla: no reconoce las tildes (´), y cambia las sílabas con tilde por una interrogación. Ya he buscado en los foros (mensajes relacionados tanto con rss como rdf, y por supuesto en el foro de xml), pero no he encontrado nada. El script, rdf.class.php, está disponible en fase4. Si alguien sabe a qué se debe esto, o conoce alguna alternativa, le estaría muy agradecido.

Gracias.
  #2 (permalink)  
Antiguo 12/11/2003, 15:52
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 5 meses
Puntos: 16
Hola,

Prueba a especificar la codificacion tanto del rss como del html a UTF-8. En el RSS seria poner

<?xml version="1.0" encoding="UTF-8"?>

y en el HTML

<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

Suerte.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
  #3 (permalink)  
Antiguo 13/11/2003, 07:34
 
Fecha de Ingreso: noviembre-2003
Mensajes: 51
Antigüedad: 14 años, 1 mes
Puntos: 0
Hola Josemi,

Gracias por tu respuesta.

Verás, en el php la única referencia que he encontrado es esto:

Código PHP:
function _parseData($parser$text
    { 
        
$text =  utf8_decode($text);
        
$clean preg_replace("/\s/"""$text); 
        if (
$clean) {

        ...
sigue... 
No sé si puedo hacer algo con eso...

No hay nada más, ni encoding, ni charset... Y lo que ponga en el html no tiene ningún efecto, ya que es el parser este el que genera el texto.

Gracias.
  #4 (permalink)  
Antiguo 15/11/2003, 16:57
 
Fecha de Ingreso: agosto-2003
Mensajes: 272
Antigüedad: 14 años, 3 meses
Puntos: 0
estas usando algun entorno de php para programar?
de ser así ese es el problema ya que seguramente es un programa pensado para eeuu.
Saludos, proba abrir el .php con bloc de notas y escribir algo con un tilde
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 07:35.