Foros del Web » Programando para Internet » PHP »

Problemas Con usuario y contraseña de entrada.

Estas en el tema de Problemas Con usuario y contraseña de entrada. en el foro de PHP en Foros del Web. Hola a todos. Bueno mi problema es el siguiente... Deje una pagina de entrada con usuario y contraseña, esta la agrege en el top.php para ...
  #1 (permalink)  
Antiguo 25/08/2005, 01:17
Usuario no validado
 
Fecha de Ingreso: noviembre-2002
Ubicación: .........
Mensajes: 147
Antigüedad: 15 años, 1 mes
Puntos: 0
Problemas Con usuario y contraseña de entrada.

Hola a todos.

Bueno mi problema es el siguiente...

Deje una pagina de entrada con usuario y contraseña, esta la agrege en el top.php para que no ingresen la url de algun modulo direectamente... si llegaran a realizar eso se ira directamente a la pantalla de uaurio y contraseña.

Bueno hasta ahi todo bien.. pero los modulos de esta pagina tiene una manera de hacer direccion a los viinculos y ... y cuando haces click en uno y no aparece la URL en el estado de la ventana (para inferior de la ventana)... se va directamente a la ventana de inicio de usuario y contraseña.... lo que no deberia hacer...

Solo funciona correctamente cuando haces click en los vinculos que aparecen en el estado de la ventana...

Ojalñas me alla explicado bien... (de todas maneras dejo 3 fotos de capturas.. mas o menos.. para que vean lo que pasa... )

en la primera foto (1.jpg) ago un click y se regresa a la pantalla de inicio...
y en la segunda funciona correctamente (2.jpg)... la foto numero tres (3.jpg) es la pantalla de entrada de usuario y contraseña... esa me aparece cuando ago click como la foto numero uno..

Si alguien me pudiera ayudar ..se los agradeceria,...

ya que me urge muchoo...

salu2 a todos ...
  #2 (permalink)  
Antiguo 25/08/2005, 01:32
Avatar de DINASEN  
Fecha de Ingreso: marzo-2003
Mensajes: 997
Antigüedad: 14 años, 9 meses
Puntos: 1
mmmm estas mezclando el autentificador de cluster con el oscommerce?
como es eso de que le has agregado el top.php para que no se ingresen directamente? eso tambien lo tiene ya el autentificador de cluster enel archivo aseverifica.inc o algo asi


lo mas simple y lo que se suele hacer con el oscomerce es proteger el directorio, eso lo puedes hacer en el cpanel de tu host tardaras 1 minuto y ya lo tendras listo

Un Saludo
  #3 (permalink)  
Antiguo 25/08/2005, 22:56
Usuario no validado
 
Fecha de Ingreso: noviembre-2002
Ubicación: .........
Mensajes: 147
Antigüedad: 15 años, 1 mes
Puntos: 0
gracias por responder pero....


Para empezar no estoy en un host arrendado... yo cree el servidor De linux y yo soy el administrador de el.. y le doy host a varias empresas .. y creo sus paginas y les ago mantecion a ellas...

Bueno el problema es que una de las empresas ya tenia su sitio ya echo por otra persona.. y lo traslade al mio... pero lo que paso es que la entrada al administracion del sitio que esta echa en php tenia una password de entrada ... la cual no pude duplicar por un servicio que no tengo habilitadio (y no pienso habilitarlo .. por X razones)... entonces hice una pagina de entrada que se conecta con una tabla de usuario y verifica entrada... a lo demas agrege esta pagina como include en el archivo de top.php (dentro de este archivo.. no agrege un TOP) .. ya que este esta incluido en todos los modulos del administrador entonces esto funciono correctamente... y para que lo deje ahi.. es para que no tomen la url de algun modulo y la peguen despues sin loguiarse... asi con eso .. tendran que logiarse si ponen la url directa de algun modulo...

pero la pagina tiene unos enlazes (para mi raros..) ..que me hacen devolverse a la pantalla de inicio.. pero cuando haces click en algunas areas el vinculo no pasa eso... (como detallo en las fotos...)..

si me pudieras ayudar... te lo agradeceria...

saludos,...
  #4 (permalink)  
Antiguo 29/08/2005, 22:37
Usuario no validado
 
Fecha de Ingreso: noviembre-2002
Ubicación: .........
Mensajes: 147
Antigüedad: 15 años, 1 mes
Puntos: 0
Alguien que me pueda ayudar...
please...
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:44.