Foros del Web » Programando para Internet » PHP »

problemas con validacion del formulario

Estas en el tema de problemas con validacion del formulario en el foro de PHP en Foros del Web. Hola, nuevemente. Hojala me puedan echar la mano con la siguiente duda. () Pues bien al hacer un redireccionamiento de mi formulario para validarlo, a ...
  #1 (permalink)  
Antiguo 11/05/2003, 07:38
 
Fecha de Ingreso: diciembre-2002
Ubicación: d.f
Mensajes: 79
Antigüedad: 15 años
Puntos: 0
problemas con validacion del formulario

Hola, nuevemente. Hojala me puedan echar la mano con la siguiente duda. ()

Pues bien al hacer un redireccionamiento de mi formulario para validarlo, a la hora de desplegar los valores de regreso , cuando se captura algún en el formulario una palabra entre comillas dobles, ya valí,, por que no se me despliega el dato. Sin embargo si capturan la palabra entre comillas simples, o varias comillas simples o una sola comilla doble, no tengo problema o sea no se pasa por alto el stripslashes que le añadi.
Otra cosa curiosa es que en los campos del formulario donde no se despliega el dato de regresopor el efecto de las comillas dobles, es solamente en los tipo text, ya que en los text_area si se despliegan los datos .

Ya comprobe que el dato si llega, pues imprimi el arreglo que contiene los elementos, por lo que el problema parece ser que es el asignamiento de mis variables dentro del formulario, pero ya le movi y no he resuelto nada, cualquier comentarios se los agradeceré.

Les envio un pequeño estracto del programa


////////////////////////////////////Si imprimo el arreglo que contiene los elementos del formulario

Campo - Valor
institucionlt \"UNAM\" <=== Comillas Dobles, que según la realidad si se pasa por un stripslashes($formulario ['institucionlt']), a la hora de desplegarlos en el formulario se desplegará como "UNAM"
ap_pt Juarez
ap_mt Pardo

////////////////////////////////////// Algunos campos del formulario que no respeta las comillas dobles
Instituci&oacute;n :
<input name="institucionda" type="text" value="<? echo stripslashes($formulario['institucionda']);?>" size="25" maxlength="40" >

Apellido paterno:
<input name="ap_pt" type="text" value="<? echo stripslashes($formulario['ap_pt']);?>" size="15" maxlength="40" >
Apellido materno:
<input name="ap_mt" type="text" value="<? echo stripslashes($formulario['ap_mt']);?>" size="15" maxlength="40" >


////////////////////////////////////// Con este tipo elementos del del formulario no tengo problemas

<textarea name="oestda" cols="60" rows="2" wrap="VIRTUAL" value="" >
<? if ( trim($formulario['oestda'])=="") $formulario['oestda']="";
else echo trim(stripslashes($formulario['oestda']));
?>
</textarea>

Nota: Estoy utilizando sesiones para el envio de la información de regreso,

Saludos!!!!!!!!!
  #2 (permalink)  
Antiguo 11/05/2003, 13:36
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Pues .. para la información de regreso es probable que te haga falta pasarle un urlencode() y urldecode() para que no tengas problemas con ciertos caracteres ...

http://www.php.net/manual/en/ref.url.php

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
  #3 (permalink)  
Antiguo 13/05/2003, 11:50
 
Fecha de Ingreso: diciembre-2002
Ubicación: d.f
Mensajes: 79
Antigüedad: 15 años
Puntos: 0
Cluster, nuevamente gracias por tus consejos


Saludos!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 07:33.