Foros del Web » Programando para Internet » PHP »

Problemas con Variables

Estas en el tema de Problemas con Variables en el foro de PHP en Foros del Web. Hola a todos Bueno tengo un problema con una variable la cual me funciona hasta una parte de la pagina, dejando lo demas.. sin funcionamiento ...
  #1 (permalink)  
Antiguo 02/11/2005, 00:02
 
Fecha de Ingreso: mayo-2005
Mensajes: 148
Antigüedad: 12 años, 7 meses
Puntos: 0
Problemas con Variables

Hola a todos

Bueno tengo un problema con una variable la cual me funciona hasta una parte de la pagina, dejando lo demas.. sin funcionamiento

Me explicare mejor:

creo un archivo "config.php"

el banner de mi web llama a ese archivo siempre. es decir que las variables que contenga el "config.php" estaran en funcion durante TODAS LAS PAGINAS YA QUE TODAS LAS PAGINAS LLAMAN AL BANNER (y el banner al "config.php")

hasta ahi bien?? ok

Pues..

cree una variable con la dire de mi web, ejemplo.

$url = "http://dire.com";

entonces en muchas paginas donde debo insertar la dire, directamente uso

<? echo $url ?>/carpeta/img.gif (ejemplo)

bien en todos mis archivos uso esa variable para insertar imagenes, fondos, de todo..

pues utilizo la variable $url en todas. pero solo me funciona en algunos blokes, paginas.. en vez de funcionar en todos/as ya que llevan esa variable. pero aun asi. solo hace caso en algunos.

Por que me pasa esto??

Aver si alguien me pueda aclarar un poco esto. :P

Saludosss!
__________________
(8)Esta es la numero uno, que te sigue a todas partes,
siempre con sus estandartes,
y un grito de corazon, RACING CAMPEON
RACING CAMPEON, en el este y el oeste,
en el norte y en el sur, brillara blanca y celeste la academia RACING CLUB y la acade, y la acade... (8)
  #2 (permalink)  
Antiguo 03/11/2005, 03:59
Avatar de jam1138
/** @package Moderador */
 
Fecha de Ingreso: julio-2004
Ubicación: sèveR led onieR lE
Mensajes: 9.368
Antigüedad: 13 años, 4 meses
Puntos: 101
Pués como dices... debería funcionar.

Se te puede decir poco --ó nada-- del por qué el error sin saber exáctamente qué haces (código). Puede ser que en alguna parte resetees (borres) la variable, puede ser que la intentes ocupar antes de ser insertada ó simplemente que la ruta la imprimas mal...

Trata de seguir el valor de dicha variable; imprimela en lugares estratégicos y averiguar en qué momento se pierde, en base a ello averiguarás el por qué. Ve el código fuente generado donde dices hay error...

Se te aconsejaría que manejes una constante (no una variable) si el valor va a ser el mismo durante toda tu aplicación: www.php.net/define

Un saludo!
__________________
٩(͡๏̯͡๏)۶
» Cómo hacer preguntas de manera inteligente «

"100 años después, la revolución no es con armas, es intelectual y digital"
  #3 (permalink)  
Antiguo 03/11/2005, 09:18
 
Fecha de Ingreso: mayo-2005
Mensajes: 148
Antigüedad: 12 años, 7 meses
Puntos: 0
Muchas gracias, estoy usando ese metodo "define" y me va perfecto

;) gracias otra vez.

Yo es que uso esa variable o bien ahora constante en varias paginas.php y templates.php por eso.. y en algunas me dio errror y en otras no. Ahora probe con una constante y sin problemas.

Saludos!
__________________
(8)Esta es la numero uno, que te sigue a todas partes,
siempre con sus estandartes,
y un grito de corazon, RACING CAMPEON
RACING CAMPEON, en el este y el oeste,
en el norte y en el sur, brillara blanca y celeste la academia RACING CLUB y la acade, y la acade... (8)
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 02:59.