Foros del Web » Programando para Internet » PHP »

Problemas en la consulta get

Estas en el tema de Problemas en la consulta get en el foro de PHP en Foros del Web. hola, a [email protected] he estado dandole vueltas al asunto y no consigo ver el fallos, no me ejecuta el script correctamente. se supone que deberia ...
  #1 (permalink)  
Antiguo 07/04/2012, 05:29
Avatar de ahaugas  
Fecha de Ingreso: agosto-2011
Ubicación: Madrid
Mensajes: 249
Antigüedad: 8 años, 4 meses
Puntos: 21
Problemas en la consulta get

hola, a [email protected] he estado dandole vueltas al asunto y no consigo ver el fallos, no me ejecuta el script correctamente.

se supone que deberia de sacarme los resultados pero no hace nada de nada y me tira errores.

os dejo el codigo a ver si vosotros encontrais el fallo que yo no veo.

Código PHP:
if(isset($_GET['action']) && (!empty($_GET['action'])) {
* * 
$pageLogin 'login';
* * include(
"layout_inc/login.php");
} else if(
$_GET['action'] == 'register'){ 
* * * *
$pageLogin $_GET['action'];
* * * * include(
"layout_inc/register.php");
} else {
* * 
header("Location: index.php");

me dice este error
Parse error: syntax error, unexpected '{' in C:\xampp\htdocs\ahaugas\login.php on line 14
y es esta parte
Código PHP:
if(isset($_GET['action']) && (!empty($_GET['action'])) { 
gracias
  #2 (permalink)  
Antiguo 07/04/2012, 05:34
Avatar de ciscoh4x0r  
Fecha de Ingreso: junio-2010
Ubicación: Londres, Inglaterra
Mensajes: 300
Antigüedad: 9 años, 5 meses
Puntos: 12
Respuesta: Problemas en la consulta get

Yo creo que lo que pasa es:
Código PHP:
Ver original
  1. if(isset($_GET['action']) && (!empty($_GET['action']))){
__________________
Algún día habrá una persona mejor que yo, pero esa persona no eres tú, ni ese momento es ahora...
  #3 (permalink)  
Antiguo 07/04/2012, 06:52
Avatar de ahaugas  
Fecha de Ingreso: agosto-2011
Ubicación: Madrid
Mensajes: 249
Antigüedad: 8 años, 4 meses
Puntos: 21
Pregunta Respuesta: Problemas en la consulta get

si pongo eso me sale

Parse error: syntax error, unexpected T_STRING in C:\xampp\htdocs\ahaugas\login.php on line 15

he intentado de cas cualquier manera y nada
  #4 (permalink)  
Antiguo 08/04/2012, 16:37
 
Fecha de Ingreso: abril-2012
Mensajes: 22
Antigüedad: 7 años, 8 meses
Puntos: 4
Respuesta: Problemas en la consulta get

He copiado y pegado tu codigo en un archivo de mi localhost, funciona bien si arreglas el problema del parentesis faltante como ciscoh dijo...

if(isset($_GET['action']) && (!empty($_GET['action'])){

por:

if(isset($_GET['action']) && (!empty($_GET['action']))){

La verdad no encuentro tu problema.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 03:44.