Foros del Web » Programando para Internet » PHP »

problemas al pasar variables en apache

Estas en el tema de problemas al pasar variables en apache en el foro de PHP en Foros del Web. Hola me he instalado el apache+mysql+phpmyadmin para usarlo en modo local, todo funciona correctamente, salvo un aspecto: cuando intento pasar una variable por un enlace ...
  #1 (permalink)  
Antiguo 29/07/2002, 10:38
 
Fecha de Ingreso: julio-2002
Mensajes: 18
Antigüedad: 15 años, 5 meses
Puntos: 0
problemas al pasar variables en apache

Hola me he instalado el apache+mysql+phpmyadmin para usarlo en modo local, todo funciona correctamente, salvo un aspecto:

cuando intento pasar una variable por un enlace del estilo:

noticias/noticias.php?numero=4

no me reconoce esa variable (es decir como si no la pasase) sin embargo al publicar la página en internet, si funciona.

Supongo que será un problema configuración de apache, pero .... ¿alguien sabría que hay que modificar?

gracias de todos modos
  #2 (permalink)  
Antiguo 29/07/2002, 11:00
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Re: problemas al pasar variables en apache

El problema no es con Apache .. es con PHP (y no es problema ..).

Edita tu php.ini de PHP y mira el estado de la directiva:
registre_globals= ON .. si esta a ON pasala a OFF ...

Revisa la documentacion del mismo php.ini y del manual de PHP oficial (<a href='ir.asp?http://www.php.net/mananual/es' target='_blank'>www.php.net/mananual/es...</a>) .. que por defecto esta a OFF en las nuevas versiones de PHP por algo (motivos de seguridad principalmente ...)

Por si quieres buscar informacion .. mira en el manual sobre:
$_GET[] .. y $_POST[] arrays ..

Un saludo,
  #3 (permalink)  
Antiguo 29/07/2002, 18:43
 
Fecha de Ingreso: julio-2002
Mensajes: 18
Antigüedad: 15 años, 5 meses
Puntos: 0
Re: problemas al pasar variables en apache

gracias, tenías razón, ya he solucionado el &quot;problema&quot; ;)

  #4 (permalink)  
Antiguo 29/07/2002, 18:54
Avatar de gomo  
Fecha de Ingreso: mayo-2002
Ubicación: [email protected]
Mensajes: 906
Antigüedad: 15 años, 7 meses
Puntos: 0
Re: problemas al pasar variables en apache



<div align="center"><img src="http://cablemodem.fibertel.com.ar/sainztrapaga/images/firma.jpg" width="435" height="70" border="0">
</div>
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:53.